Bug 1311178 - Tier: Actual files are not demoted and keep on trying to demoted deleted files
Tier: Actual files are not demoted and keep on trying to demoted deleted files
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
tier-migration
:
Depends On: 1296908
Blocks: 1317366
  Show dependency treegraph
 
Reported: 2016-02-23 09:47 EST by hari gowtham
Modified: 2016-06-16 09:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1296908
: 1317366 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:58:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-23 09:48:10 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-02-23 10:22:57 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2016-02-24 01:49:59 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2016-03-01 08:01:04 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2016-03-03 01:45:00 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Vijay Bellur 2016-03-04 00:56:19 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Vijay Bellur 2016-03-09 22:53:06 EST
REVIEW: http://review.gluster.org/13501 (Tier: Avoiding stale entries from causing demotion to stop) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 8 Vijay Bellur 2016-03-14 02:05:48 EDT
COMMIT: http://review.gluster.org/13501 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit d9b5fef0333e63db9d3b5077968254e3ea9d2af4
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Feb 23 20:09:52 2016 +0530

    Tier: Avoiding stale entries from causing demotion to stop
    
    When the parent GFID is a stale entry, the lookup on this parent
    fails and this in turn fails the demotion process.
    
    This patch will make the stale entry error to be skipped.
    
    Situation for pargfid to be stale:
    Consider a folder from a tar file. Once the tar file is untared
    the files in the tar-file will start to demote.
    when the demotion is under progress, if we tend to delete
    the actual folder, then the files under it which are
    undergoing demotion will do a lookup on the parent which was
    deleted and become stale entry. This stale entry fails the
    Lookup and this will fail the demotion of the other files(not from
    tar) that are supposed to be demoted.
    
    Change-Id: I3d47c32c4077526d477a25912b0135bab98b23fc
    BUG: 1311178
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13501
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 9 Niels de Vos 2016-06-16 09:58:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.