Bug 1317366 - Tier: Actual files are not demoted and keep on trying to demoted deleted files
Tier: Actual files are not demoted and keep on trying to demoted deleted files
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
tier-migration
:
Depends On: 1296908 1311178
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-14 02:35 EDT by hari gowtham
Modified: 2016-04-19 02:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1311178
Environment:
Last Closed: 2016-04-19 02:59:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-14 02:36:18 EDT
REVIEW: http://review.gluster.org/13692 (Tier: Avoiding stale entries from causing demotion to stop) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-03-17 01:25:16 EDT
REVIEW: http://review.gluster.org/13692 (Tier: Avoiding stale entries from causing demotion to stop) posted (#2) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2016-03-22 05:06:53 EDT
COMMIT: http://review.gluster.org/13692 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 84d378dcb3cfae9e643eb548e9861cfb274df15e
Author: hari gowtham <hgowtham@redhat.com>
Date:   Tue Feb 23 20:09:52 2016 +0530

    Tier: Avoiding stale entries from causing demotion to stop
    
        back-port of : http://review.gluster.org/#/c/13501/
    
    When the parent GFID is a stale entry, the lookup on this parent
    fails and this in turn fails the demotion process.
    
    This patch will make the stale entry error to be skipped.
    
    Situation for pargfid to be stale:
    Consider a folder from a tar file. Once the tar file is untared
    the files in the tar-file will start to demote.
    when the demotion is under progress, if we tend to delete
    the actual folder, then the files under it which are
    undergoing demotion will do a lookup on the parent which was
    deleted and become stale entry. This stale entry fails the
    Lookup and this will fail the demotion of the other files(not from
    tar) that are supposed to be demoted.
    
    >Change-Id: I3d47c32c4077526d477a25912b0135bab98b23fc
    >BUG: 1311178
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: http://review.gluster.org/13501
    >Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    >Smoke: Gluster Build System <jenkins@build.gluster.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    
    Change-Id: I80a77d149180e2a05b3d7943f370b3ef162e545b
    BUG: 1317366
    Signed-off-by: Hari Gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13692
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Kaushal 2016-04-19 02:59:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.