Bug 131130 - need to build libXdmcp as PIC
need to build libXdmcp as PIC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 132903 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-27 16:14 EDT by Colin Walters
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 10:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2004-08-27 16:14:35 EDT
Description of problem:

GDM is built as a PIC executable, and it links in libXdmcp.  Therefore
libXdmcp needs to be built as PIC.

<walters> mharris: can you build xdmcp as PIC?
<mharris> walters: libXdmcp?
<walters> mharris: yep
<mharris> it isn't already?
<walters> mharris: apparently not
<mharris> doh
<walters> mharris:
/mnt/redhat/beehive/logs/gdm-444062-x86_64-dolly.build.redhat.com.log
<mharris> file a bugzilla.  should be a one line Imakefile patch
<mharris> adding $(PICFLAGS) IIRC
<walters> in rh bz or upstream?
<mharris> either
<walters> ok
<mharris> make sure I'm on CC
Comment 2 Mike A. Harris 2004-09-16 17:30:57 EDT
Fixed in 6.8.1-2 in internal CVS, will be in rawhide soon, please
test and report back.  Set status to RAWHIDE if problem is resolved
now.

TIA
Comment 3 Mike A. Harris 2004-09-19 06:38:48 EDT
*** Bug 132903 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2004-09-21 01:07:05 EDT
6.8.1-3 is now in dist-fc3, which should be pushed to rawhide
whenever the next sync to rawhide is.  libXdmcp.a should now be
properly built with PIC flags.

Please test, and set status to RAWHIDE or ASSIGNED.

Thanks in advance.
Comment 5 Ray Strode [halfline] 2004-09-21 10:32:48 EDT
Works fine, thanks.

Note You need to log in before you can comment on or make changes to this bug.