Bug 132903 - libXdmcp.a prevents compilation of gdm
libXdmcp.a prevents compilation of gdm
Status: CLOSED DUPLICATE of bug 131130
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 23:21 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-09-18 23:21:38 EDT
Description of problem:
gcc -O2 -g -pipe -m64 -o gdm-binary -pie gdm.o display.o slave.o
server.o misc.o auth.o cookie.o xdmcp.o choose.o filecheck.o md5.o
verify-pam.o errorgui.o gdm-net.o getvt.o -Wl,--export-dynamic  -lpam
-lselinux -lattr -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
-lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -L/usr/X11R6/lib64 -lXdmcp
-lXau -lX11 -lXext /usr/lib64/libpopt.so -lXinerama
-L/home/builder/rpmbuild/BUILD/gdm-2.6.0.5/vicious-extensions -lvicious
/usr/bin/ld: /usr/X11R6/lib64/libXdmcp.a(Fill.o): relocation
R_X86_64_PC32 against `recvfrom@@GLIBC_2.2.5' can not be used when
making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status

<warren> /usr/bin/ld: /usr/X11R6/lib64/libXdmcp.a(Fill.o): relocation
R_X86_64_PC32 against `recvfrom@@GLIBC_2.2.5' can not be used when
making a shared object; recompile with -fPIC
<foo> warren: if a library is only available as an archive, it must be
compiled with -fpic
<foo> warren: so that the files can be in a DSO.  tell mharris to fix it
<warren> Is it "correct" for me to -fPIC here, or whack mharris and
wait until it is fixed?
<foo> warren: owen also said, I think, that compiling a DSO is strange
<foo> warren: no, you have to recompile libXdmcp.a

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-1
Comment 1 Mike A. Harris 2004-09-19 06:38:38 EDT

*** This bug has been marked as a duplicate of 131130 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.