This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1311384 - Host in maintenance should optionally stop glusterd services
Host in maintenance should optionally stop glusterd services
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 3.1.3
Assigned To: Ramesh N
Sachin
: ZStream
Depends On: 1303539
Blocks: Gluster-HC-1 1298156 1299184
  Show dependency treegraph
 
Reported: 2016-02-24 01:32 EST by Ramesh N
Modified: 2016-11-17 23:08 EST (History)
13 users (show)

See Also:
Fixed In Version: rhsc-3.1.3-0.71
Doc Type: Bug Fix
Doc Text:
Previously, the glusterd services were stopped automatically while moving the host to maintenance. With this fix, users can select 'Stop Glusterd services' option while moving the host to maintenance to control the behaviour.
Story Points: ---
Clone Of: 1303539
Environment:
Last Closed: 2016-06-23 01:27:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53588 None None None 2016-02-24 01:32 EST
oVirt gerrit 53642 None None None 2016-02-24 01:32 EST
oVirt gerrit 53736 None None None 2016-02-24 01:32 EST
oVirt gerrit 53788 None None None 2016-02-24 01:32 EST

  None (edit)
Description Ramesh N 2016-02-24 01:32:46 EST
+++ This bug was initially created as a clone of Bug #1303539 +++

Description of problem:

RFE Bug 1205724 introduced the feature where glusterd services are stopped when a host is in maintenance mode. This is not the desired behaviour as reported by users, as the storage may need to be functional when only vdsm maintenance is required.

We need to provide users with an option if glusterd service should be stopped when moving hosts to maintenance mode. 

Version-Release number of selected component (if applicable):


How reproducible:
NA

Actual results:


Expected results:


Additional info:
Comment 3 Triveni Rao 2016-04-04 02:12:41 EDT
this bug is verified with fixed in version of rhsc-3.1.3-0.71 and found no issues.

When moving the host in to maintenance, there is a checkbox option available for stopping gluster services. After checking that all glusterfs services are stopped.
We could move the hosts maintenance mode without stopping glusterd by not selecting the option also and checked that glsuterd is running on backend.
Comment 5 Divya 2016-06-08 03:13:14 EDT
Ramesh,

Please review and sign-off the edited text.
Comment 6 Ramesh N 2016-06-08 04:12:38 EDT
Doc text looks good. Approved.
Comment 8 errata-xmlrpc 2016-06-23 01:27:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1242

Note You need to log in before you can comment on or make changes to this bug.