Bug 131157 - Rescue Mode unusable - system crashes
Rescue Mode unusable - system crashes
Status: CLOSED DUPLICATE of bug 127530
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-08-27 19:45 EDT by George Toft
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:05:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description George Toft 2004-08-27 19:45:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
Unable to boot into rescue mode.  Error on screen reads:
Running anaconda, the Fedora Core rescue mode - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 592, in ?
    rescue.runRexcue(rootPath, not rescue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 167, in runRescue
    os.symlink('/mnt/runtime/etc/' + file, '/etc/' + file)
OSError: [Errno 17] File exists
Install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
       /mnt/runtime done
       disabling /dev/loop0
       /proc/buss/usb done
       /proc done
       /dev/pts done
       /sys done
       /tmp/ramfs done
       /selinux done
you may safely reboot your system

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  At boot prompt, enter: linux rescue
2.  See above message

Actual Results:  see above

Expected Results:  console

Additional info:

This is happening on two different machines.  CD's were checked prior 
to installation using the CD validation tool during setup.

I am placing this in the HIGH category as having a rescue disk is very 
important to recover a system and/or data.  Since the rescue CD is not 
working, systems cannot be rescued.  This needs to be fixed.
Comment 1 Jeremy Katz 2004-08-30 11:28:25 EDT

*** This bug has been marked as a duplicate of 127530 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.