Bug 1311609 - updating cdn url results in ISE
Summary: updating cdn url results in ISE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: API
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1312401 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-24 15:18 UTC by Tom McKay
Modified: 2019-09-25 21:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:02:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 12894 None None None 2016-04-22 16:25:09 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Tom McKay 2016-02-24 15:18:52 UTC
Trying to update the cdn url on the subscription's manifest import page throws an ISE:

<pre>
 | NoMethodError: undefined method `each' for nil:NilClass
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/associations/collection_association.rb:356:in `replace'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/associations/collection_association.rb:41:in `writer'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/associations/builder/association.rb:118:in `users='
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/attribute_assignment.rb:45:in `public_send'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/attribute_assignment.rb:45:in `_assign_attribute'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/protected_attributes-1.1.3/lib/active_record/mass_assignment_security/attribute_assignment.rb:67:in `block in assign_attributes'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/protected_attributes-1.1.3/lib/active_record/mass_assignment_security/attribute_assignment.rb:61:in `each'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/protected_attributes-1.1.3/lib/active_record/mass_assignment_security/attribute_assignment.rb:61:in `assign_attributes'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/protected_attributes-1.1.3/lib/active_record/mass_assignment_security/persistence.rb:64:in `block in update'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/transactions.rb:329:in `block in with_transaction_returning_status'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:201:in `block in transaction'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:209:in `within_new_transaction'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:201:in `transaction'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/transactions.rb:208:in `transaction'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/activerecord-4.1.5/lib/active_record/transactions.rb:326:in `with_transaction_returning_status'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/protected_attributes-1.1.3/lib/active_record/mass_assignment_security/persistence.rb:63:in `update'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/foreman-tasks-0.7.8/app/models/foreman_tasks/concerns/action_triggering.rb:38:in `block in update_attributes'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/foreman-tasks-0.7.8/app/models/foreman_tasks/concerns/action_triggering.rb:110:in `dynflow_task_wrap'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/foreman-tasks-0.7.8/app/models/foreman_tasks/concerns/action_triggering.rb:38:in `update_attributes'
 | /home/vagrant/git/foreman/app/controllers/concerns/api/v2/taxonomies_controller.rb:70:in `update'
 | /home/vagrant/git/katello/app/controllers/katello/api/v2/organizations_controller.rb:68:in `update'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/actionpack-4.1.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/actionpack-4.1.5/lib/abstract_controller/base.rb:189:in `process_action'
 | /home/vagrant/.rvm/gems/ruby-2.2.0/gems/actionpack-4.1.
</pre>

Comment 1 Tom McKay 2016-02-24 15:18:54 UTC
Created from redmine issue http://projects.theforeman.org/issues/12894

Comment 2 Tom McKay 2016-02-24 15:18:57 UTC
Upstream bug assigned to tomckay@redhat.com

Comment 4 Tom McKay 2016-02-29 15:29:50 UTC
*** Bug 1312401 has been marked as a duplicate of this bug. ***

Comment 5 Bryan Kearney 2016-02-29 17:07:36 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12894 has been closed
-------------
Thomas McKay
Applied in changeset commit:katello|54f872d2a301549a7ada80dbe573689f3f59a35b.

Comment 6 Jitendra Yejare 2016-03-08 14:05:16 UTC
Verified this in latest Satellite 6.2 snap 2.1 and I dont see any errors in bg while updating CDN URL.

Moving this to verified.

Comment 9 errata-xmlrpc 2016-07-27 09:02:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.