Bug 1311767 - Hostgroup not storing Activation Keys
Hostgroup not storing Activation Keys
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Partha Aji
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
: 1313330 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 18:15 EST by Partha Aji
Modified: 2016-07-27 05:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:02:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
associting of selected ak getting erased as soon as you submit the hostgroup form (83.88 KB, image/png)
2016-03-02 01:46 EST, Sachin Ghai
no flags Details
hostgroup storing activation-keys (21.60 KB, image/png)
2016-03-10 05:52 EST, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13861 None None None 2016-04-22 12:01 EDT
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 08:24:38 EDT

  None (edit)
Description Partha Aji 2016-02-24 18:15:05 EST
* Configure -> Host Groups -> New Host Group
* Create a new HG with environment, cv and activation key

Notice that the activation key parameter gets erased.
Comment 1 Partha Aji 2016-02-24 18:15:06 EST
Created from redmine issue http://projects.theforeman.org/issues/13861
Comment 2 Partha Aji 2016-02-24 18:15:09 EST
Upstream bug assigned to paji@redhat.com
Comment 3 Partha Aji 2016-02-24 18:18:17 EST
Note this has been resolved upstream -> https://github.com/Katello/katello/pull/5806
Comment 5 Bryan Kearney 2016-02-24 20:09:50 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13861 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|6c315ca0420769847c30202b93e5be9d02860bda.
Comment 8 Sachin Ghai 2016-03-02 01:44:36 EST
Its still reproducible with Satellite 6.2 Snap1. Association of selected activation-key getting erased from hostgroup as soon as you submit the hostgroup form.
Comment 9 Sachin Ghai 2016-03-02 01:46 EST
Created attachment 1132153 [details]
associting of selected ak getting erased as soon as you submit the hostgroup form
Comment 10 Brad Buckingham 2016-03-02 13:11:22 EST
*** Bug 1313330 has been marked as a duplicate of this bug. ***
Comment 11 Brad Buckingham 2016-03-02 13:12:24 EST
Moving to POST since the upstream issue is merged.
Comment 12 Partha Aji 2016-03-02 17:04:53 EST
Need to cherry pick commit 6c315ca0420769847c30202b93e5be9d02860bda from upstream again ...
Comment 13 Sachin Ghai 2016-03-10 05:49:15 EST
Verified with sat6.2 snap3. Associated activation-key doesn't get erased on submitting the host-group form.
Comment 14 Sachin Ghai 2016-03-10 05:52 EST
Created attachment 1134797 [details]
hostgroup storing activation-keys
Comment 17 errata-xmlrpc 2016-07-27 05:02:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.