Bug 1311836 - [Tier]: Endup in multiple entries of same file on client after rename which had a hardlinks
[Tier]: Endup in multiple entries of same file on client after rename which h...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.8
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
: ZStream
Depends On: 1305172 1305277
Blocks: 1282710 glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-02-25 02:25 EST by Nithya Balachandran
Modified: 2016-04-19 03:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305277
Environment:
Last Closed: 2016-04-19 03:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-25 02:29:32 EST
REVIEW: http://review.gluster.org/13517 (cluster/tier: Create linkfiles to hardlinks correctly) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2016-02-27 13:48:56 EST
COMMIT: http://review.gluster.org/13517 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit cf86db23169a47008d963a5fd608b7352b0ed0cc
Author: N Balachandran <nbalacha@redhat.com>
Date:   Thu Feb 25 12:53:07 2016 +0530

    cluster/tier: Create linkfiles to hardlinks correctly
    
    There is a bug in the way hardlinks are handled in tiered volumes.
    Ideally, the tier linkto files on the cold tier to files that are
    hardlinks to each other on the hot tier, should themselves be
    hardlinks of each other. As they are not, they end up being files
    with the same gfid but different names for the cold tier dht,
    and end up overwriting the cached-subvol information stored in the dht inode-ctx.
    
    > Change-Id: Ic658a316836e6a1729cfea848b7d212674b0edd2
    > BUG: 1305277
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/13391
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    (cherry picked from commit eb362c74db84d95aac07febf0d888bd98b3fb2b9)
    
    Change-Id: I5dd98e6d248619147974a630d7d72e1942a1cc83
    BUG: 1311836
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/13517
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:23:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.