Bug 1311908 - Edit VM dialog save action calls UpdateVmDiskCommand even though no disk change happened
Edit VM dialog save action calls UpdateVmDiskCommand even though no disk chan...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Marek Libra
Artyom
: Triaged
: 1304323 (view as bug list)
Depends On:
Blocks: 1160094
  Show dependency treegraph
 
Reported: 2016-02-25 05:02 EST by Martin Sivák
Modified: 2016-04-21 10:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.6.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:35:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
michal.skrivanek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54755 master MERGED webadmin: Avoid UpdateVmDiskCommand for hosted engine Edit VM 2016-03-23 04:16 EDT
oVirt gerrit 55125 ovirt-engine-3.6 MERGED engine: Added VmActionByVmOriginTypeValidator for Allowed Cmds 2016-03-25 03:25 EDT
oVirt gerrit 55126 ovirt-engine-3.6 MERGED webadmin: Avoid UpdateVmDiskCommand for hosted engine Edit VM 2016-03-25 03:29 EDT

  None (edit)
Description Martin Sivák 2016-02-25 05:02:57 EST
Description of problem:

Usability and UX issue. This does not break any functionality.

When the Edit VM dialog is dismissed using the OK button two backend commands are called:

UpdateVmCommand and UpdateVmDiskCommand

We only allow editing some fields for the hosted engine VM and check for it in the UpdateVmCommand. But the user always gets an error from the UpdateVmDisk command because it specifically disallows changes to hosted engine VM's disks.

This would be fine if the user actually attempted to change something in the disk area. But the error is displayed even when no disk change is requested.

Version-Release number of selected component (if applicable):

master branch, but probably 3.6 too

How reproducible:

Always

Steps to Reproduce:
1. Use hosted engine VM or change the origin type of some arbitrary VM to 6 (MANAGED_HOSTED_ENGINE)
2. Edit VM (pre 3.6.3, or ask for my patches)
3. Observe the error

Actual results:

Disk update command is always called and always shows the error message.

Expected results:

Disk update should only be executed when a change is detected.
Comment 1 Martin Sivák 2016-03-02 05:31:59 EST
*** Bug 1304323 has been marked as a duplicate of this bug. ***
Comment 2 Artyom 2016-04-13 08:55:37 EDT
Verified on rhevm-3.6.5.3-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.