Bug 131198 - Initscripts/kmodule needs to be updated to new ioctls in kernel
Initscripts/kmodule needs to be updated to new ioctls in kernel
Status: CLOSED DUPLICATE of bug 131199
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-28 23:12 EDT by Reuben Farrelly
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-08-28 23:12:53 EDT
Latest mainline (bk) kernels now deprecate the use of the older SCSI 
ioctls of which kmodule references.  This causes the following 
messages to be logged by the kernel when kmodule is run:

program kmodule is using a deprecated SCSI ioctl, please convert it 
to SG_IO
program kmodule is using a deprecated SCSI ioctl, please convert it 
to SG_IO

kmodule is obviously part of initscripts.


----LKML commit comment------

get the kernel to warn about deprecated SCSI ioctls

The non unique SCSI ioctls:

SCSI_IOCTL_SEND_COMMAND
SCSI_IOCTL_TEST_UNIT_READY
SCSI_IOCTL_BENCHMARK_COMMAND
SCSI_IOCTL_SYNC
SCSI_IOCTL_START_UNIT
SCSI_IOCTL_STOP_UNIT

Have been deprecated for a while now.  We should make the kernel
complain when a program actually uses one of them, so users have had
adequate warning before they are removed.

----------------------------------------------
Comment 1 Bill Nottingham 2004-08-29 22:31:13 EDT

*** This bug has been marked as a duplicate of 131199 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.