Bug 131199 - Remove deprecated ioctl in kudzu
Remove deprecated ioctl in kudzu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 131198 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-28 23:15 EDT by Reuben Farrelly
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1.94-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 00:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2004-08-28 23:15:12 EDT
Recent kernels display this message when they are executed:

program kudzu is using a deprecated SCSI ioctl, please convert it to 
SG_IO
program kudzu is using a deprecated SCSI ioctl, please convert it to 
SG_IO

Note that in newer Linux kernels, the following ioctls are deprecated:
SCSI_IOCTL_SEND_COMMAND
SCSI_IOCTL_TEST_UNIT_READY
SCSI_IOCTL_BENCHMARK_COMMAND
SCSI_IOCTL_SYNC
SCSI_IOCTL_START_UNIT
SCSI_IOCTL_STOP_UNIT

Therefore kudzu needs to be updated to use the newer ones...
Comment 1 Bill Nottingham 2004-08-29 22:31:21 EDT
*** Bug 131198 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-10-13 00:17:18 EDT
'Fixed' in 1.1.94-1.

Note You need to log in before you can comment on or make changes to this bug.