Bug 131215 - htt error message
Summary: htt error message
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact:
URL:
Whiteboard:
Keywords: i18n
: 131216 (view as bug list)
Depends On:
Blocks: IIIMF
TreeView+ depends on / blocked
 
Reported: 2004-08-30 03:57 UTC by Lawrence Lim
Modified: 2014-03-26 00:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 10:07:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lawrence Lim 2004-08-30 03:57:06 UTC
Description of problem:
It would be nice if htt printed out a error message too for
unknown options like htt_server does.

htt_server [-d] [-lcbasiclocale localename]
           [-ifpath_name ifpath] [-if ifname]
           [-port portnumber] [-hostname hostname]
           [-conversionkeys keys]

Version-Release number of selected component (if applicable):
im-sdk-12.0.1-1.svn1891

How reproducible:
Always

Steps to Reproduce:
1.in gnome-terminal, enter htt -h or htt --help
2.
3.
  
Actual results:
Usage: htt [-retryonerror NUM]

Expected results:
Something similar to htt_server

Additional info:

Comment 1 Lawrence Lim 2004-08-30 05:19:59 UTC
*** Bug 131216 has been marked as a duplicate of this bug. ***

Comment 2 Akira TAGOH 2004-09-14 07:24:58 UTC
Well, for htt, there is no unknown options actually. instead, not
processing the options in htt is just given to htt_server.

To clarify this bug, what do you want to do? I see htt shouldn't exits
without any messages to the terminal - it's output to the syslog,
though - if such options is given. but it's hard to fix unless we run
htt_server directly due to htt do fork twice to be daemonized and to
watch the state of htt_server.


Comment 3 Leon Ho 2004-11-08 07:46:00 UTC
Look like it is fixed on rawhide.

Comment 4 Lawrence Lim 2004-11-11 10:07:42 UTC
Closing the bug and leave the htt as it is now.


Note You need to log in before you can comment on or make changes to this bug.