Bug 1312226 - Readdirp op_ret is modified by client xlator in case of xdata_rsp presence
Readdirp op_ret is modified by client xlator in case of xdata_rsp presence
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1313448
  Show dependency treegraph
 
Reported: 2016-02-26 02:36 EST by Pranith Kumar K
Modified: 2016-06-16 09:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313448 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:58:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-02-26 02:36:28 EST
Description of problem:
While testing multi-threaded heal patch ran into this issue where op_ret comes as zero even when readdir returns some entries. Found that it happens when xdata_rsp is non-null. Multi threaded self-heal is not doing any heals because of this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-26 02:38:51 EST
REVIEW: http://review.gluster.org/13530 (protocol/client: Don't change op_ret when xdata_rsp is present) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-02-27 09:54:08 EST
REVIEW: http://review.gluster.org/13530 (protocol/client: Don't change op_ret when xdata_rsp is present) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-02-29 06:46:19 EST
COMMIT: http://review.gluster.org/13530 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 1f673d141fb06282583175357348a7a2fc19e604
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Feb 25 21:30:33 2016 +0530

    protocol/client: Don't change op_ret when xdata_rsp is present
    
    Change-Id: Ia69cc420ad7b5766d513ea2715bbca50d8d57132
    BUG: 1312226
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13530
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:58:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.