Bug 1313448 - Readdirp op_ret is modified by client xlator in case of xdata_rsp presence
Readdirp op_ret is modified by client xlator in case of xdata_rsp presence
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On: 1312226
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 10:43 EST by Pranith Kumar K
Modified: 2016-04-19 03:22 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1312226
Environment:
Last Closed: 2016-04-19 03:22:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-03-01 10:43:00 EST
+++ This bug was initially created as a clone of Bug #1312226 +++

Description of problem:
While testing multi-threaded heal patch ran into this issue where op_ret comes as zero even when readdir returns some entries. Found that it happens when xdata_rsp is non-null. Multi threaded self-heal is not doing any heals because of this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-02-26 02:38:51 EST ---

REVIEW: http://review.gluster.org/13530 (protocol/client: Don't change op_ret when xdata_rsp is present) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-27 09:54:08 EST ---

REVIEW: http://review.gluster.org/13530 (protocol/client: Don't change op_ret when xdata_rsp is present) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-02-29 06:46:19 EST ---

COMMIT: http://review.gluster.org/13530 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 1f673d141fb06282583175357348a7a2fc19e604
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Feb 25 21:30:33 2016 +0530

    protocol/client: Don't change op_ret when xdata_rsp is present
    
    Change-Id: Ia69cc420ad7b5766d513ea2715bbca50d8d57132
    BUG: 1312226
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13530
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 1 Vijay Bellur 2016-03-01 10:43:25 EST
REVIEW: http://review.gluster.org/13568 (protocol/client: Don't change op_ret when xdata_rsp is present) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-02 02:22:26 EST
COMMIT: http://review.gluster.org/13568 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 793f0ffba45e9cd6d5fbfbb8ffc274794aeb4683
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Feb 25 21:30:33 2016 +0530

    protocol/client: Don't change op_ret when xdata_rsp is present
    
     >Change-Id: Ia69cc420ad7b5766d513ea2715bbca50d8d57132
     >BUG: 1312226
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/13530
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
     >(cherry picked from commit 1f673d141fb06282583175357348a7a2fc19e604)
    
    Change-Id: I2befb42ffff7410550f2373ec2ed7c251b911ae5
    BUG: 1313448
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13568
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Mike McCune 2016-03-28 19:19:36 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Kaushal 2016-04-19 03:22:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.