This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312316 - CFME not able to recognize vm power off event when instance is shut off from Horizon.
CFME not able to recognize vm power off event when instance is shut off from...
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Red Hat CloudForms Documentation
Red Hat CloudForms Documentation
control:event:openstack
:
: 1312315 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 07:06 EST by Nikhil Gupta
Modified: 2016-05-30 01:29 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-30 01:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
policy profile (3.49 KB, text/x-vhdl)
2016-02-26 07:07 EST, Nikhil Gupta
no flags Details

  None (edit)
Description Nikhil Gupta 2016-02-26 07:06:36 EST
Description of problem:
CFME not able to recognize vm power off  event when instance is shut off from Horizon.

Made a cloudform policy, this policy only start a server when this server gets an event of vm power off.

This policy works when stop the server using cloudforms, but  when I use Horizon to power off the server, the policy doesn't work.

Version-Release number of selected component (if applicable):
cfme-5.5.0.13.20151201120956_653c0d4
Red Hat OpenStack 7

How reproducible:
Always

Steps to Reproduce:
1. Import Profiles_20160226_112922.yaml
2. Shut off instance running on OpenStack provider from Horizon

Actual results:
Instance will not power on as per the control policy.

Expected results:
Instance should power on as per the control policy.
Comment 2 Nikhil Gupta 2016-02-26 07:07 EST
Created attachment 1130826 [details]
policy profile
Comment 4 Greg McCullough 2016-02-29 09:11:37 EST
*** Bug 1312315 has been marked as a duplicate of this bug. ***
Comment 5 Greg McCullough 2016-02-29 09:27:40 EST
Need to review the policy profile but I think the first thing to validate is that the appliance is seeing the events coming from Openstack.

Nikhil - Have you verified that the event is issues from Horizon?  

You might want to confirm that powering off a VM in Horizon will emit the event from the message bus.  Maybe setup a little test scenario where he can watch amqp and power off a VM.
Comment 7 Greg McCullough 2016-03-01 15:58:27 EST
Reassigning to the Provider group to take a look at event collection.

I looked at the CFME environment and it shows that we are not collecting any events from the OpenStack provider.

irb(main):017:0> ExtManagementSystem.all.collect {|e| [e.class.name, e.name, e.ems_events.count]}
=> [
["ManageIQ::Providers::Redhat::InfraManager",    "RHEV_Nijin",  5828], ["ManageIQ::Providers::Vmware::InfraManager",    "VMware sat6",  844], ["ManageIQ::Providers::Openstack::CloudManager", "kilo1",          0], ["ManageIQ::Providers::Amazon::CloudManager",    "gss-lab",        0]
]

We need to get events collected from the provider before the policy will work.
Comment 15 Greg McCullough 2016-05-10 13:31:18 EDT
See comment #14 about missing configuration on OpenStack.
Comment 16 Lucy Bopf 2016-05-25 22:45:04 EDT
Moving to NEW to be reviewed as the schedule allows.
Comment 17 Lucy Bopf 2016-05-30 01:29:26 EDT
The following procedure for configuring the notification driver for OpenStack services (to allow Red Hat CloudForms to receive event information) is now documented and published here:

https://access.redhat.com/documentation/en/red-hat-cloudforms/version-4.0/managing-providers/#configuring_red_hat_cloudforms_to_receive_events_2


Moving this bug to CLOSED. Please reopen if any additional documentation is required.

Note You need to log in before you can comment on or make changes to this bug.