Bug 1312433 - [RFE] garbage collect stale replication controllers
[RFE] garbage collect stale replication controllers
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
zhou ying
https://github.com/kubernetes/kuberne...
:
: 1326529 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 11:52 EST by Evgheni Dereveanchin
Modified: 2016-09-28 09:12 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-28 07:38:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgheni Dereveanchin 2016-02-26 11:52:54 EST
Description of problem:
 Currently each deployment leaves a replication controller behind for rollback purposes. Eventually this leads to etcd getting filled with stale data. Also, if quotas are enforced, deployments will soon stop working due to replication controllers piling up, and the only way to clean them up is using "oadm prune"

Version-Release number of selected component (if applicable):
3.1.1

Proposed improvement:
 Allow setting replication controller limit per project or per deployment.

Additional info:
 upstream pull request was merged:
  https://github.com/kubernetes/kubernetes/pull/19590
Comment 2 Dan McPherson 2016-04-13 18:08:23 EDT
*** Bug 1326529 has been marked as a duplicate of this bug. ***
Comment 3 Michail Kargakis 2016-04-18 10:25:51 EDT
Related gh issue: https://github.com/openshift/origin/issues/6731
Comment 5 Steve Kuznetsov 2016-08-29 08:37:07 EDT
Deployment cleanup policy was added in https://github.com/openshift/origin/issues/8691 

Michal, does that satisfy this?
Comment 6 Michail Kargakis 2016-08-29 08:42:31 EDT
Yes, dc.spec.revisionHistoryLimit satisfies this bug.
Comment 7 zhou ying 2016-08-30 05:24:11 EDT
Confirmed with OCP , the issue has fixed:
openshift v3.3.0.27
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Auto cleanup the first RC, only retain the latest 3 RC;

oc get rc
NAME              DESIRED   CURRENT   AGE
history-limit-3   0         0         9m
history-limit-4   0         0         7m
history-limit-5   1         1         7m

Note You need to log in before you can comment on or make changes to this bug.