Bug 1312445 - [Ubuntu] installing redhat ceph on a node that's using an apt cache
Summary: [Ubuntu] installing redhat ceph on a node that's using an apt cache
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Christina Meno
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks: 1314455 1314456
TreeView+ depends on / blocked
 
Reported: 2016-02-26 17:22 UTC by Alfredo Deza
Modified: 2017-01-25 21:20 UTC (History)
11 users (show)

Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1314455 1314456 (view as bug list)
Environment:
Last Closed: 2016-08-23 19:31:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 2148241 None None None 2017-01-25 21:20:54 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Alfredo Deza 2016-02-26 17:22:17 UTC
Description of problem: Lack of support for deploying on a system with apt-cache


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results: apt-cacher provisioning works


Additional info:

Comment 4 Christina Meno 2016-02-26 17:57:58 UTC
need docs for setting up apt-cacher and define our requirements for working with it.

Comment 5 Ken Dreyer (Red Hat) 2016-02-29 17:43:56 UTC
apt-cacher-ng instructions are at https://access.redhat.com/articles/2148241

Comment 6 Christina Meno 2016-03-01 17:35:45 UTC
maybe split this into two tickets for RHEL and ubuntu

Comment 7 Harish NV Rao 2016-03-02 16:18:51 UTC
@gmeno and @adeza any doc needs to be modified/added as part of this?

Comment 8 Andrew Schoen 2016-03-09 21:27:49 UTC
PR for this feature here: https://github.com/ceph/ceph-ansible/pull/611

This functionality assumes that the proper apt repos are present on the system, no interaction with apt-cache was necessary and assumes anything needing to be done was completed during preflight.

Comment 12 Mike McCune 2016-03-28 22:42:18 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 18 Federico Lucifredi 2016-08-10 16:13:56 UTC
Last testing status (from email and program call) is that this is working correctly for  DMZ-hosted package caches, primed with ISOs or with packages from rhos.download.redhat.com. 

Remaining is the configuration with no network connection at all, which is producing some DNS errors.

Comment 19 Tejas 2016-08-19 15:33:24 UTC
Tested this in the RC and CDN stage testing.
Moving this to Verified state.

Comment 21 errata-xmlrpc 2016-08-23 19:31:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755


Note You need to log in before you can comment on or make changes to this bug.