Bug 1312559 - Ceph Infrastructure nodes page fails to show details with error ' Unexpected error encountered'
Ceph Infrastructure nodes page fails to show details with error ' Unexpected ...
Status: CLOSED DUPLICATE of bug 1312560
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All Linux
unspecified Severity medium
: GA
: 5.6.0
Assigned To: Dan Clarizio
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-27 06:38 EST by Jaison Raju
Modified: 2016-02-29 16:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 16:55:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaison Raju 2016-02-27 06:38:02 EST
Description of problem:
All Ceph Overcloud Nodes page fails to show details with error ' Unexpected error encountered' 
production.log
[----] I, [2016-02-27T11:59:39.042089 #12792:563998]  INFO -- : Processing by HostController#show as HTML
[----] I, [2016-02-27T11:59:39.042214 #12792:563998]  INFO -- :   Parameters: {"id"=>"9r6"}
[----] F, [2016-02-27T11:59:39.106835 #12792:563998] FATAL -- : Error caught: [NoMethodError] undefined method `<<' for nil:NilClass
/var/www/miq/vmdb/app/controllers/application_controller.rb:1414:in `block in set_config'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation/delegation.rb:46:in `each'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation/delegation.rb:46:in `each'
/var/www/miq/vmdb/app/controllers/application_controller.rb:1387:in `set_config'
/var/www/miq/vmdb/app/controllers/host_controller.rb:30:in `show'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'


Version-Release number of selected component (if applicable):
cfme-5.5.0.13-2.el7cf.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add Director environment using ceph nodes, in Infrastructure .
2. Access Ceph Nodes from Infrastructure -> Node Tab.
3.

Actual results:
Error Page seen instead of node page .

Expected results:
All node pages including ceph overcloud nodes are accessible .

Additional info:
PFA production.log , evm.log & screenshot
Comment 2 Greg Blomquist 2016-02-29 16:55:32 EST

*** This bug has been marked as a duplicate of bug 1312560 ***

Note You need to log in before you can comment on or make changes to this bug.