Bug 1312560 - Ceph Infrastructure nodes page fails to show details with error ' Unexpected error encountered'
Summary: Ceph Infrastructure nodes page fails to show details with error ' Unexpected ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: GA
: 5.6.0
Assignee: Martin Hradil
QA Contact: Omri Hochman
URL:
Whiteboard: openstack
: 1312559 1354611 (view as bug list)
Depends On:
Blocks: 1358494
TreeView+ depends on / blocked
 
Reported: 2016-02-27 11:38 UTC by Jaison Raju
Modified: 2018-07-25 16:48 UTC (History)
9 users (show)

Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1358494 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:39:53 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
production.log (1.88 MB, text/plain)
2016-02-27 11:46 UTC, Jaison Raju
no flags Details
evm.log (10.41 MB, text/plain)
2016-02-27 11:47 UTC, Jaison Raju
no flags Details
screen (82.38 KB, image/png)
2016-02-27 11:48 UTC, Jaison Raju
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Jaison Raju 2016-02-27 11:38:32 UTC
Description of problem:
All Ceph Overcloud Nodes page fails to show details with error ' Unexpected error encountered' 
production.log
[----] I, [2016-02-27T11:59:39.042089 #12792:563998]  INFO -- : Processing by HostController#show as HTML
[----] I, [2016-02-27T11:59:39.042214 #12792:563998]  INFO -- :   Parameters: {"id"=>"9r6"}
[----] F, [2016-02-27T11:59:39.106835 #12792:563998] FATAL -- : Error caught: [NoMethodError] undefined method `<<' for nil:NilClass
/var/www/miq/vmdb/app/controllers/application_controller.rb:1414:in `block in set_config'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation/delegation.rb:46:in `each'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/relation/delegation.rb:46:in `each'
/var/www/miq/vmdb/app/controllers/application_controller.rb:1387:in `set_config'
/var/www/miq/vmdb/app/controllers/host_controller.rb:30:in `show'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'


Version-Release number of selected component (if applicable):
cfme-5.5.0.13-2.el7cf.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add Director environment using ceph nodes, in Infrastructure .
2. Access Ceph Nodes from Infrastructure -> Node Tab.
3.

Actual results:
Error Page seen instead of node page .

Expected results:
All node pages including ceph overcloud nodes are accessible .

Additional info:
PFA production.log , evm.log & screenshot

Comment 2 Jaison Raju 2016-02-27 11:46:00 UTC
Created attachment 1131070 [details]
production.log

Comment 3 Jaison Raju 2016-02-27 11:47:16 UTC
Created attachment 1131071 [details]
evm.log

Comment 5 Jaison Raju 2016-02-27 11:48:52 UTC
Created attachment 1131072 [details]
screen

Comment 6 Greg Blomquist 2016-02-29 21:55:32 UTC
*** Bug 1312559 has been marked as a duplicate of this bug. ***

Comment 9 CFME Bot 2016-03-23 15:50:49 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/94b9a07a0f08e7c41663422e6f73c38ad249e5e8

commit 94b9a07a0f08e7c41663422e6f73c38ad249e5e8
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Mar 10 14:24:29 2016 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Mar 17 20:55:54 2016 +0000

    ApplicationController#set_config - add 2 failing specs
    
    one is to catch `"" + nil` and the other `nil << ""`
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1312560

 spec/controllers/application_controller_spec.rb | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comment 10 CFME Bot 2016-03-23 15:50:54 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/97092ffef33cf72972f7a5c55a2997c2e6510a16

commit 97092ffef33cf72972f7a5c55a2997c2e6510a16
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Mar 10 14:28:03 2016 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Mar 17 21:00:42 2016 +0000

    ApplicationController#set_config - fix string+nil concatentation errors
    
    For some cases nil was handled but not others - forcing loc, dev, desc and icon to always be a string.
    
    + handle the case of empty or singler letter dev (`""[1..-1]` is nil)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1312560

 app/controllers/application_controller.rb | 19 ++++++++++++++-----
 1 file changed, 14 insertions(+), 5 deletions(-)

Comment 11 Ronnie Rasouli 2016-06-09 14:14:26 UTC
verified on 5.6.0.10 CEPH pages accessible

Comment 13 errata-xmlrpc 2016-06-29 15:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Comment 14 CFME Bot 2016-07-12 19:20:55 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d51c469a50ac225477a7f668f8385eea44ba12e2

commit d51c469a50ac225477a7f668f8385eea44ba12e2
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Mar 10 14:28:03 2016 +0000
Commit:     Marek Aufart <maufart@redhat.com>
CommitDate: Tue Jul 12 09:51:09 2016 +0200

    ApplicationController#set_config - fix string+nil concatentation errors
    
    For some cases nil was handled but not others - forcing loc, dev, desc and icon to always be a string.
    
    + handle the case of empty or singler letter dev (`""[1..-1]` is nil)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1312560

 app/controllers/application_controller.rb | 18 +++++++++++++-----
 1 file changed, 13 insertions(+), 5 deletions(-)

Comment 15 CFME Bot 2016-07-12 19:21:00 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=98a251f7c812001df0044fe109a32323316cd4cf

commit 98a251f7c812001df0044fe109a32323316cd4cf
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Mar 10 14:24:29 2016 +0000
Commit:     Marek Aufart <maufart@redhat.com>
CommitDate: Tue Jul 12 09:48:08 2016 +0200

    ApplicationController#set_config - add 2 failing specs
    
    one is to catch `"" + nil` and the other `nil << ""`
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1312560

 spec/controllers/application_controller_spec.rb | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comment 16 Marek Aufart 2016-07-14 08:10:29 UTC
*** Bug 1354611 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.