This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1312580 - GStreamermm 1.0 is not packaged in Fedora Rawhide
GStreamermm 1.0 is not packaged in Fedora Rawhide
Status: NEW
Product: Fedora
Classification: Fedora
Component: gstreamermm (Show other bugs)
rawhide
All All
unspecified Severity high
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1299945
  Show dependency treegraph
 
Reported: 2016-02-27 10:17 EST by Russel Winder
Modified: 2017-09-14 04:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russel Winder 2016-02-27 10:17:11 EST
The gstreamermm package in Fedora Rawhide is for GStreamer 0.10 which has been redundant since the release of GStreamer 1.0 many moons ago.

Debian Sid has withdrawn it's gstreamermm 0.10 packages in favour of it's gstreamermm 1.0 packages leaving Fedora Rawhide seeming out of date and behind the times.
Comment 1 Ankur Sinha (FranciscoD) 2016-03-08 14:00:41 EST
I've submitted a package review here: https://bugzilla.redhat.com/show_bug.cgi?id=1315852

I only need the package for subtitleeditor - I'll be really happy if you folks (the current gstreamermm maintainers) would please take over the package once it's reviewed?

Cheers,
Ankur
Comment 2 Jan Kurik 2016-07-26 00:29:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 3 Ben Asselstine 2017-03-12 15:37:33 EDT
I'm the developer of lordsawar, and I need gstreamermm-1.0 packaged.  I waited a while hoping this would happen, but waiting hasn't helped.

As Russell mentioned, Debian is deprecating gstreamermm-0.10, so I'm moving ahead with 1.0 which will unfortunately break the lordsawar package in Fedora unless this is packaged.
Comment 4 Rémi Verschelde 2017-03-12 15:52:42 EDT
gstreamermm-1.0 seems to be packaged as gstreamer in F25 and Rawhide: https://src.fedoraproject.org/cgit/rpms/gstreamermm.git/log/gstreamermm.spec

So this bug report can be closed as RESOLVED FIXED.
Comment 5 Ben Asselstine 2017-03-12 16:01:31 EDT
Thank you!  (I was looking for a gstreamermm-1.0 package and didn't see one)
Comment 6 Russel Winder 2017-09-14 04:58:11 EDT
gstreamermm-1.0 is packaged but:

1. it is tied to gstreamer-0.10 instead of gstreamer-1.0; and
2. it is version 1.4.3 and 1.8.0 is the current version.

Note You need to log in before you can comment on or make changes to this bug.