Bug 1312725 - Installing foreman-libvirt causes hammer to print warning to stdout
Summary: Installing foreman-libvirt causes hammer to print warning to stdout
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Packaging
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1312929 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-29 04:28 UTC by Og Maciel
Modified: 2019-09-26 16:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:02:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13948 None None None 2016-04-22 16:21:00 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Og Maciel 2016-02-29 04:28:58 UTC
Description of problem:

We had an abismall number of failures in our automation with the latest Satellite 6.2 build, but the good news is that these are all false negatives. The issue is caused by the fact that many of our automation around hosts and compute resources relies on using libvirt, which requires the foreman-libvirt package. Since we install this packae during the provisioning step for our CI, whenever we run a CLI command, we also capture the return code of every command executed as well as any stdout, stderr messages returned by hammer.

Right now, when you run hammer, the following message is returned as stderr:

Ignoring ruby-libvirt-0.5.2 because its extensions are not built.  Try: gem pristine ruby-libvirt --version 0.5.2

So our assertions that a command is successfully executed are all failing because of this.

Can someone help us out with this? I'd hate to add 'logic' to our framework to look at error messages and ignore specifically this. Also, this means that our customers would also see this, which is suboptimal imo.

Version-Release number of selected component (if applicable):

Satellite 6.2.0 Compose 1

How reproducible:


Steps to Reproduce:
1. Install foreman-libvirt onto a Satellite 6.2.0 Compose 1 system
2. Use hammer command to create a new organization with minimal required fields
3.

Actual results:

The organization gets created but you do end up with a warning message displayed in the output


Expected results:


Additional info:

Comment 1 Og Maciel 2016-02-29 04:29:41 UTC
As per Eric Helms:

>> This occurs upstream as well right now and originates from tfm-rubygem-ruby-libvirt which comes from installing foreman-libvirt to get the compute resource.

Comment 3 Bryan Kearney 2016-02-29 15:04:28 UTC
Upstream bug component is Packaging

Comment 5 orabin 2016-03-02 15:18:14 UTC
*** Bug 1312929 has been marked as a duplicate of this bug. ***

Comment 6 Bryan Kearney 2016-03-03 15:04:30 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13948 has been closed
-------------
Dominic Cleal
Applied in changeset commit:182a53a814cf1946721dbd1dfe2c3e33e00c0805.

Comment 8 Roman Plevka 2016-04-01 13:58:42 UTC
VERIFIED:

This has been fixed since 6.2.0 Snap3

Comment 9 Roman Plevka 2016-04-01 14:01:14 UTC
(In reply to Roman Plevka from comment #8)
> VERIFIED:
> 
> This has been fixed since 6.2.0 Snap3

# hammer -u admin -p changeme organization create --name foo
Organization created

Comment 11 errata-xmlrpc 2016-07-27 09:02:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.