Bug 1312929 - hammer --help is failing with a warning
hammer --help is failing with a warning
Status: CLOSED DUPLICATE of bug 1312725
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Tazim Kolhar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 09:42 EST by Tazim Kolhar
Modified: 2016-04-25 20:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 10:18:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2016-02-29 09:42:48 EST
Description of problem:
hammer --help is failing with a warning

Version-Release number of selected component (if applicable):
$ rpm -qa | grep foreman
gsutclif-foremandemo1.osop.rhcloud.com-foreman-proxy-client-1.0-1.noarch
gsutclif-foremandemo1.osop.rhcloud.com-qpid-client-cert-1.0-1.noarch
foreman-release-scl-2-1.el7.x86_64
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-5.el7.noarch
tfm-rubygem-foreman_docker-2.0.1-1.fm1_11.el7.noarch
foreman-selinux-1.12.0-0.develop.201602191056git869d1b0.el7.noarch
foreman-proxy-1.12.0-0.develop.201602251412git7e896ba.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.10-1.fm1_12.el7.noarch
foreman-gce-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
foreman-vmware-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
foreman-release-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
foreman-libvirt-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
gsutclif-foremandemo1.osop.rhcloud.com-puppet-client-1.0-1.noarch
tfm-rubygem-hammer_cli_foreman-0.6.0-2.201602251420git361b8e8.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-4.el7.noarch
foreman-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
foreman-compute-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
tfm-rubygem-foreman-tasks-0.7.14-1.fm1_11.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-5.el7.noarch
gsutclif-foremandemo1.osop.rhcloud.com-apache-1.0-1.noarch
gsutclif-foremandemo1.osop.rhcloud.com-qpid-broker-1.0-1.noarch
foreman-postgresql-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
gsutclif-foremandemo1.osop.rhcloud.com-qpid-router-client-1.0-1.noarch
tfm-rubygem-foreman_hooks-0.3.9-2.fm1_11.el7.noarch
foreman-ovirt-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
gsutclif-foremandemo1.osop.rhcloud.com-qpid-router-server-1.0-1.noarch
gsutclif-foremandemo1.osop.rhcloud.com-foreman-proxy-1.0-1.noarch
gsutclif-foremandemo1.osop.rhcloud.com-parent-cert-1.0-1.noarch
foreman-debug-1.12.0-0.develop.201602251134git8a7d34d.el7.noarch
gsutclif-foremandemo1.osop.rhcloud.com-foreman-client-1.0-1.noarch


How reproducible:
everytime

Steps to Reproduce:
1.$ hammer --help
Ignoring ruby-libvirt-0.5.2 because its extensions are not built.  Try: gem pristine ruby-libvirt --version 0.5.2
Usage:
    hammer [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 activation-key                Manipulate activation keys.
 architecture                  Manipulate architectures.
 auth                          Foreman connection login/logout.
 auth-source                   Manipulate auth sources.
 bootdisk                      Download boot disks
 capsule                       Manipulate capsule
 compute-resource              Manipulate compute resources.
 content-host                  Manipulate content hosts on the server
 content-report                View Content Reports
 content-view                  Manipulate content views.
 defaults                      Defaults management
 docker                        Manipulate docker content
 domain                        Manipulate domains.
 environment                   Manipulate environments.
 erratum                       Manipulate errata
 fact                          Search facts.
 filter                        Manage permission filters.
 global-parameter              Manipulate global parameters.
 gpg                           Manipulate GPG Key actions on the server
 host                          Manipulate hosts.
 host-collection               Manipulate host collections
 hostgroup                     Manipulate hostgroups.
 import                        Import data exported from a Red Hat Satellite 5 instance
 lifecycle-environment         Manipulate lifecycle_environments on the server
 location                      Manipulate locations.
 medium                        Manipulate installation media.
 model                         Manipulate hardware models.
 organization                  Manipulate organizations
 os                            Manipulate operating system.
 package                       Manipulate packages.
 package-group                 Manipulate package groups
 partition-table               Manipulate partition tables.
 ping                          Get the status of the server
 product                       Manipulate products.
 proxy                         Manipulate smart proxies.
 puppet-class                  Search puppet modules.
 puppet-module                 View Puppet Module details.
 recurring-logic               Recurring logic related actions.
 report                        Browse and read reports.
 repository                    Manipulate repositories
 repository-set                Manipulate repository sets on the server
 role                          Manage user roles.
 sc-param                      Manipulate smart class parameters.
 settings                      Change server settings.
 shell                         Interactive shell
 smart-variable                Manipulate smart variables.
 subnet                        Manipulate subnets.
 subscription                  Manipulate subscriptions.
 sync-plan                     Manipulate sync plans
 task                          Tasks related actions.
 template                      Manipulate config templates.
 user                          Manipulate users.
 user-group                    Manage user groups.

Options:
 --autocomplete LINE           Get list of possible endings
 --csv                         Output as CSV (same as --output=csv)
 --csv-separator SEPARATOR     Character to separate the values
 --interactive INTERACTIVE     Explicitly turn interactive mode on/off
                               One of true/false, yes/no, 1/0.
 --output ADAPTER              Set output format. One of [base, table, silent, csv, yaml, json]
 --show-ids                    Show ids of associated resources
 --version                     show version
 -c, --config CFG_FILE         path to custom config file
 -d, --debug                   show debugging output
 -h, --help                    print help
 -p, --password PASSWORD       password to access the remote system
 -r, --reload-cache            force reload of Apipie cache
 -s, --server SERVER           remote system address
 -u, --username USERNAME       username to access the remote system
 -v, --verbose                 be verbose

2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 orabin 2016-03-02 10:18:14 EST
This is caused for the same reason as BZ 1312725.
The warning is present in all hammer commands so I'm closing this as a dup.
The solution for: 1312725 will solve the rest of the commands too.

*** This bug has been marked as a duplicate of bug 1312725 ***

Note You need to log in before you can comment on or make changes to this bug.