Bug 1312767 - POST /katello/api/organizations does not return any data
POST /katello/api/organizations does not return any data
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.2.0
x86_64 All
unspecified Severity high (vote)
: Beta
: --
Assigned To: Roman Plevka
Katello QA List
http://projects.theforeman.org/issues...
: AutomationBlocker, Triaged
: 1313079 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 04:10 EST by Oleksandr Shtaier
Modified: 2016-09-12 07:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:02:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some details for requests and responses from server (16.39 KB, text/plain)
2016-03-03 05:26 EST, Oleksandr Shtaier
no flags Details
verification of a bug - the post request and its response (13.83 KB, text/plain)
2016-03-25 19:32 EDT, Roman Plevka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13950 None None None 2016-04-22 11:35 EDT

  None (edit)
Description Oleksandr Shtaier 2016-02-29 04:10:52 EST
Description of problem:
POST /katello/api/organizations request does not return data.

Request:
https://my_server/katello/api/organizations
{"name":"Test_Org_011"}

Response:
{}

For example, when I create similar request for architecture entity, I get some data:
Request
POST https://my_server/api/architectures
{"architecture":{"name":"Test_Arch_011"}}

Response:
{"created_at":"2016-02-29 08:54:53 UTC","updated_at":"2016-02-29 08:54:53 UTC","name":"Test_Arch_011","id":28,"operatingsystems":[],"images":[]}

Or in older versions (6.1.x) we have next output for organization entity:
Request:
https://my_server/katello/api/organizations
{"name":"Test_Org_011"}

Response:
{"ancestry":null,"apply_info_task_id":null,"created_at":"2016-02-29T09:06:28Z","description":null,"id":812,"ignore_types":[],"katello_default":true,"label":"Test_Org_011","name":"Test_Org_011","title":"Test_Org_011","updated_at":"2016-02-29T09:06:28Z","service_levels":[],"service_level":null}

Version-Release number of selected component (if applicable):
6.2.0 BETA

How reproducible:
Always

Steps to Reproduce:
1. Try to create new organization entity


Actual results:
Empty payload returned from the server in response

Expected results:
All necessary data is present in response

Additional info:
Comment 2 Brad Buckingham 2016-02-29 10:51:57 EST
Created redmine issue http://projects.theforeman.org/issues/13950 from this bug
Comment 3 Brad Buckingham 2016-02-29 10:59:00 EST
Upstream Katello PR: https://github.com/Katello/katello/pull/5821
Comment 4 Bryan Kearney 2016-02-29 16:10:42 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13950 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|fe7570939d3ca406e005406919c0e5ff17c4d117.
Comment 5 Elyézer Rezende 2016-02-29 17:00:13 EST
*** Bug 1313079 has been marked as a duplicate of this bug. ***
Comment 7 Oleksandr Shtaier 2016-03-03 05:25:28 EST
Two questions:
1) Is it intended behavior that all POST requests to server return 201 status code, but only that one start to return 200 and only after current fix?
2) Is it intended to return so much data in response (like internal information - 'defaultServiceLevel', 'logLevel', 'redhat_repository_url',  and etc)?

Adding attachment with more details
Comment 8 Oleksandr Shtaier 2016-03-03 05:26 EST
Created attachment 1132721 [details]
Some details for requests and responses from server
Comment 9 Roman Plevka 2016-03-25 19:32 EDT
Created attachment 1140476 [details]
verification of a bug - the post request and its response

VERIFIED

using 6.2 Snap5.1
Comment 12 errata-xmlrpc 2016-07-27 05:02:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.