This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313079 - Organization create API call don't return the ID of created entity
Organization create API call don't return the ID of created entity
Status: CLOSED DUPLICATE of bug 1312767
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 16:45 EST by Elyézer Rezende
Modified: 2016-02-29 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 17:00:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elyézer Rezende 2016-02-29 16:45:07 EST
Description of problem:
When doing a API create request for Organization it is not returning the ID of the created entity. Actually it is returning an empty dictionary.


Version-Release number of selected component (if applicable):
6.2.0-Beta-SNAP1

How reproducible:
Always

Steps to Reproduce:
1. Do a POST request to /katello/api/organizations
2. Check the content returned
3.

Actual results:
No data is returned

Expected results:
At least the created entity ID is returned

Additional info:
2016-02-29 18:41:26 - nailgun.client - DEBUG - Making HTTP POST request to https://sat-server.example.com:443/katello/api/v2/organizations with options {'verify': False, 'auth': ('admin', 'changeme'), 'headers': {'content-type': 'application/json'}} and data {"name": "\ud868\udd89\u9c32\ub23c\ud7dc\ud843\udc4d\ud845\udfd5\u8da9\ud86b\udee2\ud85d\ude80"}.
2016-02-29 18:41:34 - nailgun.client - DEBUG - Received HTTP 201 response: {}
Comment 1 Elyézer Rezende 2016-02-29 17:00:13 EST

*** This bug has been marked as a duplicate of bug 1312767 ***

Note You need to log in before you can comment on or make changes to this bug.