Bug 1312830 - tests fail because bug-924726.t depends on netstat
Summary: tests fail because bug-924726.t depends on netstat
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Sven
QA Contact:
URL:
Whiteboard:
Depends On: 1312832
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-29 10:44 UTC by Niels de Vos
Modified: 2018-06-20 17:56 UTC (History)
5 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1312832 (view as bug list)
Environment:
Last Closed: 2018-06-20 17:56:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-02-29 10:44:58 UTC
Description of problem:

./tests/bugs/bug-924726.t: line 30: netstat: command not found
./tests/bugs/bug-924726.t: line 39: netstat: command not found


Version-Release number of selected component (if applicable):
3.6.9

How reproducible:
100%

Steps to Reproduce:
1. run https://ci.centos.org/view/Storage-SIG/job/storage-sig-gluster-upstream-regression/ on CentOS-6 with release-3.6 packages

Actual results:
Among the failures, there is this:

./tests/bugs/bug-924726.t: line 30: netstat: command not found
./tests/bugs/bug-924726.t: line 39: netstat: command not found


Expected results:
run-tests.sh should complain if dependencies are missing.

Comment 2 Sven 2018-03-10 23:54:10 UTC
please assign to me, Thank you!

Comment 3 Niels de Vos 2018-03-12 08:58:44 UTC
(In reply to Sven from comment #2)
> please assign to me, Thank you!

Done. Let us know if you have any difficulties with making the modifications. Thanks!

Comment 4 Worker Ant 2018-03-12 22:09:37 UTC
REVIEW: https://review.gluster.org/19701 (run-tests.sh: added dependency check for netstat) posted (#1) for review on master by

Comment 5 Worker Ant 2018-03-13 13:01:02 UTC
COMMIT: https://review.gluster.org/19701 committed in master by  with a commit message- run-tests.sh: added dependency check for netstat

Because bug-924726.t depends on netstat, tests failed before. This got resolved
by adding respective check to run-tests.sh.

Enabled respective test again.

Change-Id: I70c9bff03379ed9ee8cd95842c3501dfb50b8e86
BUG: 1312830
Signed-off-by: Sven Fischer <sven@fischer-abc.de>

Comment 6 Shyamsundar 2018-06-20 17:56:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.