Bug 1312832 - tests fail because bug-924726.t depends on netstat
Summary: tests fail because bug-924726.t depends on netstat
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1316432
Blocks: 1312830
TreeView+ depends on / blocked
 
Reported: 2016-02-29 10:48 UTC by Niels de Vos
Modified: 2018-10-23 15:06 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1312830
Environment:
Last Closed: 2018-10-23 15:06:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-02-29 10:48:45 UTC
+++ This bug was initially created as a clone of Bug #1312830 +++
+++                                                           +++
+++ Use this bug to send a fix for the master branch.         +++

Description of problem:

./tests/bugs/bug-924726.t: line 30: netstat: command not found
./tests/bugs/bug-924726.t: line 39: netstat: command not found


Version-Release number of selected component (if applicable):
3.6.9

How reproducible:
100%

Steps to Reproduce:
1. run https://ci.centos.org/view/Storage-SIG/job/storage-sig-gluster-upstream-regression/ on CentOS-6 with release-3.6 packages

Actual results:
Among the failures, there is this:

./tests/bugs/bug-924726.t: line 30: netstat: command not found
./tests/bugs/bug-924726.t: line 39: netstat: command not found


Expected results:
run-tests.sh should complain if dependencies are missing.

Comment 1 Vijay Bellur 2016-02-29 11:19:05 UTC
REVIEW: http://review.gluster.org/13547 (tests: check for the availability of netstat) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Vijay Bellur 2016-03-09 07:11:40 UTC
REVIEW: http://review.gluster.org/13547 (tests: check for the availability of netstat) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Mike McCune 2016-03-28 23:11:51 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 4 Vijay Bellur 2016-04-26 15:26:51 UTC
REVIEW: http://review.gluster.org/13547 (tests: check for the availability of netstat) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 5 Worker Ant 2018-06-26 07:22:27 UTC
REVIEW: https://review.gluster.org/13547 (tests: check for the availability of netstat) posted (#4) for review on master by Niels de Vos

Comment 6 Worker Ant 2018-06-26 14:50:17 UTC
COMMIT: https://review.gluster.org/13547 committed in master by "Niels de Vos" <ndevos@redhat.com> with a commit message- tests: check for the availability of netstat

bug-924726.t calls netstat, and tests fail in case netstat is not
available.

BUG: 1312832
Change-Id: I3393778e148504326a468744d8a97d28932feed1
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 7 Shyamsundar 2018-10-23 15:06:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.