Bug 1312851 - [abrt] yumex-dnf: status.py:139:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
[abrt] yumex-dnf: status.py:139:handle_dbus_signals:AttributeError: 'NoneType...
Status: CLOSED DUPLICATE of bug 1269400
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:8fa96550e328e8d4d28cc20894f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 06:56 EST by Rafal Luzynski
Modified: 2016-03-22 08:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 08:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (869 bytes, text/plain)
2016-02-29 06:56 EST, Rafal Luzynski
no flags Details
File: environ (1.01 KB, text/plain)
2016-02-29 06:56 EST, Rafal Luzynski
no flags Details

  None (edit)
Description Rafal Luzynski 2016-02-29 06:56:06 EST
Description of problem:
I launched yumex-dnf and it did not show any updates available. I know there should be some updates available because I'd seen them the other day. I closed the window and launched yumex-dnf again. It presented me a message dialog telling that yumex-dnf is already running and whether I want to quit. I chose "Yes" and it quit, nothing more happened. I lanuched it again and when asked whether I want to quit I chose "No" this time. It reported a crash, that's all.

Now when I was writing this comment I saw another message dialog telling that yumex-dnf could not refresh the cache. The only option was to close that dialog box and when I closed it it crashed again. So I have another crash report waiting in a queue, although I don't yet know if I would report it.

Version-Release number of selected component:
yumex-dnf-4.1.4-1.fc22

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.3.4-200.fc22.x86_64
runlevel:       N 5
type:           Python3
uid:            500

Truncated backtrace:
status.py:139:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 73, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 127, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 139, in handle_dbus_signals
    self.app.win.on_status_icon_clicked(force=True)
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
sender: ':1.71'
proxy: <DBusProxy object at 0x7f03ebbba558 (GDBusProxy at 0x25481c0)>
args: (2646,)
self: <yumex.status.StatusIcon object at 0x7f03ebbb96a0>
run_pid: 2646
signal: 'ShowSignal'

Potential duplicate: bug 1277714
Comment 1 Rafal Luzynski 2016-02-29 06:56:10 EST
Created attachment 1131510 [details]
File: backtrace
Comment 2 Rafal Luzynski 2016-02-29 06:56:11 EST
Created attachment 1131511 [details]
File: environ
Comment 3 Rafal Luzynski 2016-02-29 07:14:14 EST
Indeed, it looks like a duplicate of bug 1277714 which is a duplicate of bug 1269400. In bug 1269400 comment 12 you said that an update has been pushed to the Fedora 22 testing repository: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8054ed53d3 but it has been residing in testing for 3 months already and has not been pushed to stable so this is the reason why it still could happen to me. I have not tested this update but I guess it's OK to push it to stable.
Comment 4 Rafal Luzynski 2016-03-22 08:59:24 EDT
Closing as yumex-dnf-4.1.5-1.fc22 from https://bodhi.fedoraproject.org/updates/FEDORA-2015-8054ed53d3 has been pushed to stable.

*** This bug has been marked as a duplicate of bug 1269400 ***

Note You need to log in before you can comment on or make changes to this bug.