Bug 131294 - after upgrade from 2.6.8-1.526 to 2.6.8-1.533, service amd restart caused Badness in interruptible_sleep_on_timeout
after upgrade from 2.6.8-1.526 to 2.6.8-1.533, service amd restart caused Bad...
Status: CLOSED DUPLICATE of bug 127018
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-30 15:09 EDT by Daniel Reed
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Reed 2004-08-30 15:09:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
[root@localhost ~]# service amd restart
Stopping amd: Badness in interruptible_sleep_on_timeout at
kernel/sched.c:3004
 [<022f7064>] interruptible_sleep_on_timeout+0x5d/0x23a
 [<0211b5bd>] default_wake_function+0x0/0xc
 [<22edc9e6>] lockd_down+0xb4/0x258 [lockd]
 [<22f2e40a>] nfs_kill_super+0x43/0x63 [nfs]
 [<0216790e>] deactivate_super+0xcb/0xe0
 [<02184484>] sys_umount+0x65/0x6c
 [<021526e8>] unmap_vma_list+0xe/0x17
 [<02152a9a>] do_munmap+0x1e1/0x1eb
 [<02184496>] sys_oldumount+0xb/0xe
                                                           [  OK  ]
Starting amd: nfs warning: mount version older than kernel
                                                           [  OK  ]
[root@localhost ~]# uname -a
Linux localhost 2.6.8-1.533 #1 Sat Aug 28 13:28:41 EDT 2004 i686 i686
i386 GNU/Linux
[root@localhost ~]#

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.533

How reproducible:
Couldn't Reproduce
Comment 1 Daniel Reed 2004-09-10 10:33:04 EDT
This still occurs with 2.6.8-1.541, and is present in FC3-re0908.0.
Comment 2 Matthew Kent 2004-09-17 17:09:45 EDT
Same crash, different software. This server doing some heavy MySQL
work and tanked with this error after a day of uptime.

Badness in interruptible_sleep_on_timeout at kernel/sched.c:3004

Call Trace:<ffffffff80318447>{interruptible_sleep_on_timeout+119}
       <ffffffff801327fb>{default_wake_function+0}
<ffffffffa018d6d8>{:lockd:lockd_down+206}
       <ffffffff80181d5f>{kill_anon_super+91}
<ffffffffa01a380e>{:nfs:nfs_kill_super+77}
       <ffffffff801808d1>{deactivate_super+137}
<ffffffff8019ac58>{sys_umount+1377}
       <ffffffff80198637>{generic_drop_inode+428}
<ffffffff801935e6>{dput+58}
       <ffffffff8017a07f>{filp_close+103}
<ffffffff8017a15d>{sys_close+215}
       <ffffffff8011021a>{system_call+126}

2.6.8-1.541smp #1 SMP Wed Sep 1 18:13:47 EDT 2004 x86_64 x86_64 x86_64
GNU/Linux
Comment 3 Warren Togami 2004-09-18 15:40:04 EDT
http://people.redhat.com/arjanv/2.6/
Please see if this is still an issue with the 582+ kernels from here.
Comment 4 Matthew Kent 2004-09-21 10:37:57 EDT
Okay installed 2.6.8-1.584smp #1 SMP Mon Sep 20 06:58:26 EDT 2004
x86_64 x86_64 x86_64 GNU/Linux yesterday. Shortly after a cron which
tars up some configs and fires them across an nfs mount (automount)
ran I got the same crash which took down 1/6 mysql instances on the
server.

Badness in interruptible_sleep_on_timeout at kernel/sched.c:3004

Call Trace:<ffffffff802f069d>{interruptible_sleep_on_timeout+121}
       <ffffffff80130fee>{default_wake_function+0}
<ffffffffa017a3e8>{:lockd:lockd_down+201}
       <ffffffffa019060a>{:nfs:nfs_kill_super+77}
<ffffffff8017585a>{deactivate_super+95}
       <ffffffff8018ac3f>{sys_umount+925}
<ffffffff8016fd70>{filp_close+103}
       <ffffffff8016fe06>{sys_close+143}
<ffffffff80110036>{system_call+126}

I can reproduce the crash reliably by running the following
tar czf /misc/backup/minibackups/$HOSTNAME\_nagios.tar.gz /etc/nagios
--ignore-failed-read

automounter entry look like
backup -rw,vers=3,rsize=8192,wsize=8192,timeo=14,intr,noatime
172.16.0.16:/home/backup_demo
Comment 5 Daniel Reed 2004-09-30 10:25:02 EDT
This still occurs with 2.6.8-1.590, and is present in rawhide-20040930.

[root@dhcp83-9 ~]# service amd stop
Stopping amd: Badness in interruptible_sleep_on_timeout at
kernel/sched.c:3004
 [<022ff2bc>] interruptible_sleep_on_timeout+0x5d/0x23a
 [<0211b869>] default_wake_function+0x0/0xc
 [<22e3aa66>] lockd_down+0xb4/0x258 [lockd]
 [<22ef6439>] nfs_kill_super+0x43/0x63 [nfs]
 [<0216a2aa>] deactivate_super+0xcb/0xe0
 [<02186f18>] sys_umount+0x65/0x6c
 [<02154d06>] unmap_vma_list+0xe/0x17
 [<021550e5>] do_munmap+0x20e/0x218
 [<02186f2a>] sys_oldumount+0xb/0xe

[root@dhcp83-9 ~]#
Comment 6 Elliot Lee 2004-10-13 16:09:15 EDT

*** This bug has been marked as a duplicate of 127018 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:05:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.