Bug 1312954 - quota: xattr trusted.glusterfs.quota.limit-objects not healed on a root of newly added brick
quota: xattr trusted.glusterfs.quota.limit-objects not healed on a root of ne...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1306218 1306220
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 10:43 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1306220
Environment:
Last Closed: 2016-04-19 03:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-29 10:46:58 EST
REVIEW: http://review.gluster.org/13551 (quota: heal object-limit on a root dir of a newly added brick) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-03-04 01:15:43 EST
COMMIT: http://review.gluster.org/13551 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 1da6a7525eb83f429c6f6ef2bba58c0adf3f64aa
Author: vmallika <vmallika@redhat.com>
Date:   Wed Feb 10 16:27:05 2016 +0530

    quota: heal object-limit on a root dir of a newly added brick
    
    This is a backport of http://review.gluster.org/13422
    
    When a new brick is added, xattr trusted.glusterfs.quota.limit-objects
    is not healed on a root directory.
    This patch will fix the problem
    
    > Change-Id: I776609ebf4d7822c541b6262e63d465ea3a86db4
    > BUG: 1306220
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/13422
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I47412b4da35c0f5d28106020daf32212d267cb9e
    BUG: 1312954
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13551
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Kaushal 2016-04-19 03:22:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.