Bug 1312955 - unable to delete selinux filesystems (/tmp/mock-selinux-plugin.*)
unable to delete selinux filesystems (/tmp/mock-selinux-plugin.*)
Status: CLOSED DUPLICATE of bug 1312820
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 10:51 EST by Ralf Corsepius
Modified: 2016-03-03 04:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 04:03:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2016-02-29 10:51:14 EST
Description of problem:

Whenever I am running "fedpkg mockbuild" or "mock", I am facing a warning similar to this one, at the very end of such a build job:

...
INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-x86_64/result
Finish: run
WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.38oyne4r): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.38oyne4r'
...

Version-Release number of selected component (if applicable):
mock-1.2.15-1.fc23.noarch
selinux-policy-targeted-3.13.1-158.7.fc23.noarch

How reproducible:
Always.

Steps to Reproduce:
1. mock build an arbitrary package and watch the terminal output.


Actual results:
- The warning above
- Each mock run creates a file named /tmp/mock-selinux-plugin.*.
  These are gradually piling up with each mock run.

Additional info:
- This behavior started with today's Fedora update.
- No idea, whether the culprit is mock, selinux or else.
Comment 1 Kamil Dudka 2016-03-03 04:03:31 EST

*** This bug has been marked as a duplicate of bug 1312820 ***

Note You need to log in before you can comment on or make changes to this bug.