Bug 1312971 - "Init Processes" doesn't list symlinked services
"Init Processes" doesn't list symlinked services
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Hui Song
Pavol Kotvan
ui:smartstate
: ZStream
Depends On:
Blocks: 1314389
  Show dependency treegraph
 
Reported: 2016-02-29 11:34 EST by Vadim Rutkovsky
Modified: 2016-06-29 11:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1314389 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:40:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2016-02-29 11:34:29 EST
Description of problem:
"Init processes" doesn't list some services after SSA is performed on the instance

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
Always

Steps to Reproduce:
1. Prepare the appliance for fleecing (smartstate role, vddk etc.)
2. Spin up any fedora-based VM (I used F22)
3. Compare 'Init Processes' list with systemctl output on the VM

Actual results:
Init Processes doesn't list services which are put in /usr/lib/systemd/system via symlinking, e.g. dracut-* and dbus-* services are not listed, while those are present in 'systemctl list-unit-files --type service' output:

# ls -la /usr/lib/systemd/system/dracut-cmdline.service 
lrwxrwxrwx. 1 root root 55 Jun 16  2015 /usr/lib/systemd/system/dracut-cmdline.service -> ../../dracut/modules.d/98systemd/dracut-cmdline.service

Expected results:
All services which can be started are listed

Additional info:
Comment 5 errata-xmlrpc 2016-06-29 11:40:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.