Bug 1314389 - "Init Processes" doesn't list symlinked services
Summary: "Init Processes" doesn't list symlinked services
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis   
(Show other bugs)
Version: 5.5.0
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.5.3
Assignee: Rich Oliveri
QA Contact: Ramesh A
URL:
Whiteboard: ui:smartstate
Keywords: ZStream
Depends On: 1312971
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-03 13:40 UTC by John Prause
Modified: 2017-08-30 01:17 UTC (History)
7 users (show)

Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1312971
Environment:
Last Closed: 2016-04-13 18:45:31 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0616 normal SHIPPED_LIVE CFME 5.5.3 bug fixes and enhancement update 2016-04-13 22:38:44 UTC

Description John Prause 2016-03-03 13:40:19 UTC
+++ This bug was initially created as a clone of Bug #1312971 +++

Description of problem:
"Init processes" doesn't list some services after SSA is performed on the instance

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
Always

Steps to Reproduce:
1. Prepare the appliance for fleecing (smartstate role, vddk etc.)
2. Spin up any fedora-based VM (I used F22)
3. Compare 'Init Processes' list with systemctl output on the VM

Actual results:
Init Processes doesn't list services which are put in /usr/lib/systemd/system via symlinking, e.g. dracut-* and dbus-* services are not listed, while those are present in 'systemctl list-unit-files --type service' output:

# ls -la /usr/lib/systemd/system/dracut-cmdline.service 
lrwxrwxrwx. 1 root root 55 Jun 16  2015 /usr/lib/systemd/system/dracut-cmdline.service -> ../../dracut/modules.d/98systemd/dracut-cmdline.service

Expected results:
All services which can be started are listed

Additional info:

Comment 3 Ramesh A 2016-04-01 09:26:39 UTC
Good to go.  Verified and working fine in 5.5.3.2.20160318152106_92d2d67

Now CFME displays all the services listed in 'systemctl list-unit-files --type service' output.

Comment 5 errata-xmlrpc 2016-04-13 18:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616


Note You need to log in before you can comment on or make changes to this bug.