Bug 1313019 - capsule-certs-generate : specifying the incorrect rpm as part of output
capsule-certs-generate : specifying the incorrect rpm as part of output
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Brad Buckingham
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
: 1313788 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 13:08 EST by Brad Buckingham
Modified: 2016-07-27 05:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:02:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13956 None None None 2016-04-22 12:39 EDT

  None (edit)
Description Brad Buckingham 2016-02-29 13:08:10 EST
Description of problem:

The installation procedures for a capsule include running 'capsule-certs-generate' from the server.  The output of that command provides the user with guidance on how to install the capsule.  Unfortunately, it is instructing the user to install an non-existing package. 

How reproducible:
Always

Steps to Reproduce:
1. install Satellite
2. export CAPSULE=<capsule_fqdn>
3. capsule-certs-generate --capsule-fqdn "$CAPSULE" --certs-tar "~/$CAPSULE-certs.tar"


Actual results:

Output mentions the following:

  1. Ensure that the katello-installer-capsule package is installed on the system.

Expected results:

'katello-installer-capsule' needs to be replaced with 'foreman-installer-katello'

Additional info:
Comment 1 Brad Buckingham 2016-02-29 13:10:30 EST
Created redmine issue http://projects.theforeman.org/issues/13956 from this bug
Comment 2 Brad Buckingham 2016-02-29 13:15:21 EST
Fixed upstream with: https://github.com/Katello/katello-installer/pull/307
Comment 4 Brad Buckingham 2016-03-02 13:18:27 EST
*** Bug 1313788 has been marked as a duplicate of this bug. ***
Comment 5 Kedar Bidarkar 2016-03-10 08:43:49 EST
To finish the installation, follow these steps:

  1. Ensure that the foreman-installer-katello package is installed on the system.


VERIFIED with Sat62-SNAP3-compose1
Comment 8 errata-xmlrpc 2016-07-27 05:02:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.