Bug 1313788 - capsule-certs-generate cmd suggests a wrong package for capsule
capsule-certs-generate cmd suggests a wrong package for capsule
Status: CLOSED DUPLICATE of bug 1313019
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Kedar Bidarkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 05:58 EST by Kedar Bidarkar
Modified: 2016-03-02 13:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-02 13:18:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kedar Bidarkar 2016-03-02 05:58:07 EST
Description of problem:

capsule-certs-generate cmd suggests a wrong package be installed on capsule

~]# capsule-certs-generate --capsule-fqdn $CAPSULE_FQDN --certs-tar ~/$CAPSULE_FQDN-certs.tar
Installing             Info: START 21                                     [0%] [Installing             Info: RESOURCE Package[katello-certs-tools]        [4%] 
Installing             Done                                               [100%]Installing             Done                                               [100%] []
  Success!

  To finish the installation, follow these steps:

  1. Ensure that the katello-installer-capsule package is installed on the system.


Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP1

How reproducible:


Steps to Reproduce:
1. Run capsule-certs-generate
2.
3.

Actual results:
capsule-certs-generate cmd suggests a wrong package be installed on capsule


Expected results:
capsule-certs-generate cmd should suggest correct package be installed on capsule.


Additional info:

Looks like installing capsule-installer package fetches,

Package capsule-installer-2.5.0.4-1.el7sat.noarch is obsoleted by foreman-installer-katello-3.0.0.0-1.el7sat.noarch which is already installed

Not sure which is the right package, "foreman-installer-katello" or "foreman-installer-capsule" ?
Comment 2 Brad Buckingham 2016-03-02 13:18:27 EST
The correct package should be foreman-installer-katello.  This issue was fixed under bug 1313019; however, it did not make it in this current snap.

*** This bug has been marked as a duplicate of bug 1313019 ***

Note You need to log in before you can comment on or make changes to this bug.