Bug 131305 - oocalc cannot save files without crashing
oocalc cannot save files without crashing
Status: CLOSED DUPLICATE of bug 130734
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-30 15:57 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 12:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2004-08-30 15:57:20 EDT
oocalc is crashing for me (on x86) when I try to save an existing (or
new) spreadsheet, i've tried 1.1.2-3 and 1.1.2-2, with the same effect.

[spot@localhost ~]$ oocalc
Use of uninitialized value in string at /usr/bin/oocalc line 355.
Use of uninitialized value in string at /usr/bin/oocalc line 355.
sh: bug-buddy: command not found


Fatal exception: Signal 11
Stack:
/usr/lib/ooo-1.1/program/libsal.so.3[0xedcc40]
/usr/lib/ooo-1.1/program/libsal.so.3[0xedcd67]
/usr/lib/ooo-1.1/program/libsal.so.3[0xedce14]
/lib/tls/libpthread.so.0[0xa65318]
/usr/lib/ooo-1.1/program/libxo645li.so
(_ZN11SvXMLExport12AddAttributeEtN6xmloff5token12XMLTokenEnumERKN3rtl8OUStringE+0x48)[0xf3527b8a]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf28941a6]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf288edc9]
/usr/lib/ooo-1.1/program/libxo645li.so
(_ZN11SvXMLExport17ImplExportContentEv+0x3f)[0xf3527f0b]
/usr/lib/ooo-1.1/program/libxo645li.so
(_ZN11SvXMLExport9exportDocEN6xmloff5token12XMLTokenEnumE
+0x750)[0xf352868a]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf289b335]
/usr/lib/ooo-1.1/program/libxo645li.so
(_ZN11SvXMLExport6filterERKN3com3sun4star3uno8SequenceINS2_5beans13PropertyValueEEE+0xd8)[0xf35274ee]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf289b478]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf287ae42]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf287c056]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf2442d88]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf24444c5]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxObjectShell15SaveAsOwnFormatER9SfxMedium+0x1d2)[0xf39682d0]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxObjectShell11SaveTo_ImplER9SfxMediumPK10SfxItemSeth
+0x266)[0xf3962784]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxObjectShell16PreDoSaveAs_ImplERK6StringS2_P10SfxItemSet
+0x31c)[0xf3967bfc]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxObjectShell17CommonSaveAs_ImplERK13INetURLObjectRK6StringP10SfxItemSet+0x49e)[0xf3967626]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxObjectShell14GUISaveAs_ImplEhP10SfxRequest+0x399e)[0xf3971d48]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxObjectShell13ExecFile_ImplER10SfxRequest+0x17de)[0xf397381c]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_Z34SfxStubSfxObjectShellExecFile_ImplP8SfxShellR10SfxRequest
+0x1a)[0xf396dd3e]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN8SfxShell11ExecuteSlotER10SfxRequestPK12SfxInterface
+0xa4)[0xf39ff07a]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf24a9aef]
/usr/lib/ooo-1.1/program/libsc645li.so[0xf249e42e]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN13SfxDispatcher9Call_ImplER8SfxShellRK7SfxSlotR10SfxRequesth
+0x511)[0xf39f3a2d]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN13SfxDispatcher8_ExecuteER8SfxShellRK7SfxSlotR10SfxRequestt
+0x14b)[0xf39f4bc1]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN11SfxBindings12Execute_ImplER10SfxRequestPK7SfxSlotP8SfxShell
+0x2d9)[0xf3a0217d]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN11SfxBindings12Execute_ImplEtPPK11SfxPoolItemttS3_h
+0x307)[0xf3a01e0b]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN11SfxBindings7ExecuteEtPPK11SfxPoolItemttS3_+0x3f)[0xf3a01ab7]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxVirtualMenu6SelectEP4Menu+0x462)[0xf3a19c44]
/usr/lib/ooo-1.1/program/libsfx645li.so
(_ZN14SfxVirtualMenu14LinkStubSelectEPvS0_+0x1a)[0xf3a197dc]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN4Menu6SelectEv+0x48)[0x2b7cb2]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN4Menu14ImplCallSelectEPS_+0x13)[0x2bafc9]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN4Menu22LinkStubImplCallSelectEPvS0_+0x1a)[0x2bafb0]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so[0x2f8f31]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_Z19ImplWindowFrameProcPvP8SalFrametPKv+0x2d5)[0x2f9541]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN12SalFrameData19HandleClientMessageEP19XClientMessageEvent
+0x7f)[0x34f3ed]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN12SalFrameData8DispatchEP7_XEvent+0x40f)[0x34fa67]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN10SalDisplay8DispatchEP7_XEvent+0x260)[0x378f88]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN10SalDisplay5YieldEh+0x113)[0x378d0d]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so[0x3759fc]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN7SalXLib5YieldEh+0x390)[0x37472e]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN11SalInstance5YieldEh+0x29)[0x37bbf3]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN11Application5YieldEv+0x53)[0x1e00d5]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so
(_ZN11Application7ExecuteEv+0x2d)[0x1e000d]
/usr/lib/ooo-1.1/program/soffice.bin(_ZN7desktop7Desktop4MainEv
+0x1984)[0x80646e2]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so(_Z6SVMainv
+0x42)[0x1e4312]
/usr/lib/ooo-1.1/program/widgets/default/libvcl645li.so(main
+0x38)[0x373444]
/lib/tls/libc.so.6(__libc_start_main+0xe3)[0x626ea93]
/usr/lib/ooo-1.1/program/soffice.bin
(_ZN6Window11RequestHelpERK9HelpEvent+0x31)[0x805ed51]
Aborted

All I'm doing is opening the attached document, then attempting to
save it to my homedir. 

Ideas? (The uninitialized value appears to be WINDOWMANAGER)
Comment 1 Tom "spot" Callaway 2004-09-15 00:11:18 EDT
Dan, this crash goes away when I go back to openoffice.org-1.1.1-4. I
suspect this is due to the compiler optimization change.
Comment 2 Dan Williams 2004-09-15 00:16:28 EDT
Yes, I've verified this crash goes away with what will become 1.1.2-5...
Comment 3 Dan Williams 2004-09-15 13:32:58 EDT

*** This bug has been marked as a duplicate of 130734 ***
Comment 4 Caolan McNamara 2004-10-05 12:14:50 EDT
close as duplicate, fixed in >= openoffice.org-1.1.2-5

Note You need to log in before you can comment on or make changes to this bug.