Bug 130734 - oocalc segfaults when saving
oocalc segfaults when saving
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 131305 131810 132777 132891 133308 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-23 20:59 EDT by Sammy
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 12:02:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-08-23 20:59:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en) (KHTML, like Gecko)

Description of problem:
oocalc is crashing when one tries to save a file after making any change OR
just start ocalc type in some cells and choose save! Going back to version
1.1.1-6 from test1 cures the problem.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-3

How reproducible:
Always

Steps to Reproduce:
1.start oocalc
2.type in a cell
3.choose save
    

Additional info:
Comment 1 Sammy 2004-08-25 11:42:35 EDT
Additional info: If i install openoffice 1.1.2 from the distribution tar file there 
is no segfault. Seems to depend on local build. 
Comment 2 Gerry Tool 2004-08-28 12:38:29 EDT
I am having the same problem with openoffice.org-1.1.2-3 installed via
up2date.

[gerry@gstpc ~]$ rpm -q openoffice.org
openoffice.org-1.1.2-3
[gerry@gstpc ~]$ oocalc
Use of uninitialized value in string at /usr/bin/oocalc line 355.
Use of uninitialized value in string at /usr/bin/oocalc line 355.
sh: bug-buddy: command not found
Segmentation fault

Comment 3 Sammy 2004-09-09 10:13:30 EDT
What is happening with this issue? Is it a gcc-3.4.1 problem? There 
seems to be enough patches for compiling oo with gcc-3.4.1 now. 
Also, perhaps the recent ximian updates to 1.1.2 may fix it. 
Thanks 
Comment 4 Dan Williams 2004-09-09 14:14:48 EDT
AFAIK, 1.1.x will never compile with gcc 3.4 since it had fairly
substantial changes to get it to work with the current 2.0 code.  The
problem may well be a result of using -Os to compile OOo rather than -O1.
Comment 5 victor lorenz 2004-09-10 08:37:54 EDT
*** Bug 131810 has been marked as a duplicate of this bug. ***
Comment 6 Colin Charles 2004-09-12 12:13:27 EDT
Eh, running 1.1.2-3, I can't repeat this crash in ooocalc. This is on
PPC. But on x86, I can repeat this bug (and it is a blocker for FC3,
imho).
Comment 7 Sammy 2004-09-12 17:09:22 EDT
Well, the it would be nice if we have a recompilation with a different 
level of optimization for x86 architecture. I wanted to compile it but 
it requires me to install too many new packages to be able to do so. 
Could we have -O1 compilation instead of -Os to see if this is the 
problem. 1.1.3 is coming up soon so this would be nice. 
Comment 8 Dan Williams 2004-09-12 20:52:20 EDT
I'm going to take out the -Os patch in the next update.
Comment 9 Dan Williams 2004-09-15 13:33:05 EDT
*** Bug 131305 has been marked as a duplicate of this bug. ***
Comment 10 Dan Williams 2004-09-16 22:09:59 EDT
*** Bug 132777 has been marked as a duplicate of this bug. ***
Comment 11 Dan Williams 2004-09-18 17:27:42 EDT
*** Bug 132891 has been marked as a duplicate of this bug. ***
Comment 12 Dan Williams 2004-09-23 03:13:35 EDT
*** Bug 133308 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2004-09-24 12:02:08 EDT
Please test with the openoffice.org-1.1.2-5 RPMs in Rawhide, it should
be fixed in that version.  If the problem persists with that version,
please reopen this bug.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.