Bug 1313098 - liveinst does not work in Wayland (consolehelper)
liveinst does not work in Wayland (consolehelper)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 1310403 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 18:13 EST by Adam Williamson
Modified: 2016-03-26 14:14 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-24.13.1-1 anaconda-24.13.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:14:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2016-02-29 18:13:43 EST
Recent F24 / Rawhide Workstation live images boot to Wayland (when they work at all). The live installer does not launch from the welcome screen or the overview. This is because the launcher runs /usr/bin/liveinst , which attempts to run /usr/sbin/liveinst through the consolehelper system. consolehelper (and most other methods for running GUI apps 'as root') does not work under Wayland: that is https://bugzilla.redhat.com/show_bug.cgi?id=1274451 . We are filing this issue separately because this *specific* case (the live installer) is a clear release blocking bug, and it may be possible to solve it in some way other than 'make consolehelper work on Wayland', so it's useful to have a specific bug. We could, for instance, elevate privileges via PolicyKit in some way.

I've actually tested and verified the bug, BTW, it's no longer theoretical - I booted the 2016-02-25 Rawhide Workstation nightly live on bare metal with enforcing=0. That booted to Wayland (I get X in VMs, for some reason) and indeed the installer fails to run. If you run /usr/bin/liveinst from a console you see a couple of "Unable to init server: Could not connect: Connection refused" errors, then anaconda gets very confused and dies in a sad pile of GTK+ errors.

Proposing as an Alpha blocker, this violates "The installer must run when launched normally from the release-blocking images." - https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria#Installer_must_run
Comment 1 Adam Williamson 2016-03-02 11:22:30 EST
Per today's workstation meeting:

https://meetbot.fedoraproject.org/fedora-meeting/2016-03-02/workstation.2016-03-02-15.00.html

it seems like Wayland-by-default is likely being delayed, but the decision doesn't appear *entirely* clear so I'm going to leave this as a proposed blocker at least until we see the default actually change back.
Comment 2 David Shea 2016-03-02 16:02:26 EST
https://github.com/rhinstaller/anaconda/pull/537

If wayland continues to be the default in rawhide it'd be nice to have it fixed there anyway.
Comment 3 Giulio 'juliuxpigface' 2016-03-06 03:50:18 EST
*** Bug 1310403 has been marked as a duplicate of this bug. ***
Comment 4 Kamil Páral 2016-03-07 12:18:48 EST
Discussed at today's blocker review meeting [1]. Accepted as an Alpha blocker - as the bits currently stand, this is a clear blocker. switching the lives back to X (as will apparently happen) would be an acceptable resolution.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-07/
Comment 5 Adam Williamson 2016-03-08 14:00:40 EST
gnome-session-3.19.91-2 landed in F24 today and reverted to X11, which makes this bug no longer a blocker, per #c4. Dropping blocker status.
Comment 6 Fedora Update System 2016-03-09 11:32:09 EST
anaconda-24.13.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d85d9ad927
Comment 7 Fedora Update System 2016-03-09 20:55:05 EST
anaconda-24.13.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d85d9ad927
Comment 8 Fedora Update System 2016-03-26 14:14:45 EDT
anaconda-24.13.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.