Bug 1313228 - promotions and demotions not happening after attach tier due to fix layout taking very long time(3 days)
Summary: promotions and demotions not happening after attach tier due to fix layout ta...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard: tier-migration
Depends On: 1294790
Blocks: 1299184 1323016
TreeView+ depends on / blocked
 
Reported: 2016-03-01 08:41 UTC by Joseph Elwin Fernandes
Modified: 2016-06-16 13:58 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1294790
: 1323016 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:58:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-03-01 08:44:23 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background + T file entry for cold tier.) posted (#6) for review on master by Joseph Fernandes

Comment 2 Vijay Bellur 2016-03-01 08:46:51 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background + T file entry for cold tier.) posted (#7) for review on master by Joseph Fernandes

Comment 3 Vijay Bellur 2016-03-03 01:12:44 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background + T file entry for cold tier.) posted (#8) for review on master by Joseph Fernandes

Comment 4 Vijay Bellur 2016-03-03 14:31:15 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background + T file entry for cold tier.) posted (#9) for review on master by Joseph Fernandes

Comment 5 Vijay Bellur 2016-03-07 19:58:25 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background + T file entry for cold tier.) posted (#10) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 6 Vijay Bellur 2016-03-09 08:04:36 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background + T file entry for cold tier.) posted (#11) for review on master by Joseph Fernandes

Comment 7 Vijay Bellur 2016-03-22 09:30:35 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background) posted (#12) for review on master by Joseph Fernandes

Comment 8 Vijay Bellur 2016-03-28 03:06:33 UTC
REVIEW: http://review.gluster.org/13491 (tier/dht : Attach tier fix layout to run in background) posted (#13) for review on master by Joseph Fernandes

Comment 9 Vijay Bellur 2016-03-28 16:18:06 UTC
COMMIT: http://review.gluster.org/13491 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit b67e569b3906d99677a1349cb82668f9088cf4eb
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Feb 23 12:51:45 2016 +0530

    tier/dht : Attach tier fix layout to run in background
    
    1. Spawn a thread for background fix-layout for tier process.
    
    2. Once the fix-layout is completed a marker xttr is set on the root of
       volume to mark the completion of the background fixlayout, so that
       even if the tier process is spawned again, fixlayout will not be
       issued, if it was completed last time.
    
    3. Please note that promotion of legacy files will happen eventually as
       the ctr lookup heal in the fixlayout slowly heals the ctr db for legacy
       files OR the ctr lookup heal happend due to a name lookup.
    
    4. When a detach tier is successful in evacuation data from hot tier, we remove
       the marker xattr is removed. So that next attach tier runs the background
       tier fixlayout.
    
    what is remaining ?
    1. Instead of clearing the marker xattr of tiering fix layout at the end of detach start
       clear it during detach commit. But the issue is detach commit is a glusterd operation
       and the volume is not mounted in glusterd.
       The reason we want to do it in detach commit is that if the admin wants to attach the
       same tier again, then a background fixlayout will be triggered, which would not be needed.
    2. Clearing the CTR DB of the cold bricks when there is a detach commit, as it will be having
       entries which will be stale when the volume is used, with ctr off (ctr is switched off only when
       we have detach commit.)
    
    Change-Id: Ibe343572e95865325cd0eef4d0b976b626a3c0c5
    BUG: 1313228
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/13491
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Joseph Fernandes
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 10 Niels de Vos 2016-06-16 13:58:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.