Bug 1323016 - promotions and demotions not happening after attach tier due to fix layout taking very long time(3 days)
Summary: promotions and demotions not happening after attach tier due to fix layout ta...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.10
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: bugs@gluster.org
URL:
Whiteboard: tier-migration
Depends On: 1294790 1313228
Blocks: 1299184
TreeView+ depends on / blocked
 
Reported: 2016-04-01 01:10 UTC by Joseph Elwin Fernandes
Modified: 2016-04-19 07:13 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.11
Doc Type: Bug Fix
Doc Text:
Clone Of: 1313228
Environment:
Last Closed: 2016-04-19 07:13:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-01 01:22:10 UTC
REVIEW: http://review.gluster.org/13879 (tier/dht : Attach tier fix layout to run in background) posted (#1) for review on release-3.7 by Joseph Fernandes

Comment 2 Vijay Bellur 2016-04-01 10:55:40 UTC
COMMIT: http://review.gluster.org/13879 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit ff4ceab95fea5108db2d1acebfa6ea231e2845e4
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Feb 23 12:51:45 2016 +0530

    tier/dht : Attach tier fix layout to run in background
    
    1. Spawn a thread for background fix-layout for tier process.
    
    2. Once the fix-layout is completed a marker xttr is set on the root of
       volume to mark the completion of the background fixlayout, so that
       even if the tier process is spawned again, fixlayout will not be
       issued, if it was completed last time.
    
    3. Please note that promotion of legacy files will happen eventually as
       the ctr lookup heal in the fixlayout slowly heals the ctr db for legacy
       files OR the ctr lookup heal happend due to a name lookup.
    
    4. When a detach tier is successful in evacuation data from hot tier, we remove
       the marker xattr is removed. So that next attach tier runs the background
       tier fixlayout.
    
    what is remaining ?
    1. Instead of clearing the marker xattr of tiering fix layout at the end of detach start
       clear it during detach commit. But the issue is detach commit is a glusterd operation
       and the volume is not mounted in glusterd.
       The reason we want to do it in detach commit is that if the admin wants to attach the
       same tier again, then a background fixlayout will be triggered, which would not be needed.
    2. Clearing the CTR DB of the cold bricks when there is a detach commit, as it will be having
       entries which will be stale when the volume is used, with ctr off (ctr is switched off only when
       we have detach commit.)
    
    Backport of http://review.gluster.org/13491
    
    > Change-Id: Ibe343572e95865325cd0eef4d0b976b626a3c0c5
    > BUG: 1313228
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/13491
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: Joseph Fernandes
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: Ic28affdf78d2ac0f394f3dd59f0126df7915d609
    BUG: 1323016
    Reviewed-on: http://review.gluster.org/13879
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
    Tested-by: Joseph Fernandes
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Kaushal 2016-04-19 07:13:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.11, please open a new bug report.

glusterfs-3.7.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026321.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.