This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1313299 - Calamari must push events to salt event bus based on the config file.
Calamari must push events to salt event bus based on the config file.
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari (Show other bugs)
1.3.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Gregory Meno
Harish NV Rao
:
Depends On:
Blocks: 1291304
  Show dependency treegraph
 
Reported: 2016-03-01 06:04 EST by Darshan
Modified: 2016-08-23 15:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: calamari-server-1.4.0-rc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:31:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darshan 2016-03-01 06:04:48 EST
Description of problem:
Calamari must push events to salt event bus, if the calamari.conf file has an entry "emit_events_to_salt_event_bus" set to true.

currently due to some probable environment variable issue, calamari is not able to push events to salt event bus.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set the emit_events_to_salt_event_bus= True in calamari.conf
2. simulate osd/mon event
3. check in salt event bus for these events

Actual results:
Events are not pushed to salt event bus.

Expected results:
Events must be pushed to salt event bus when the configuration is set.

Additional info:
Comment 3 Gregory Meno 2016-04-20 01:51:21 EDT
curl https://chacra.ceph.com/r/calamari/1.4/centos/7/x86_64/calamari-server-1.4.0-rc8_3_g87c85f0.el7.centos.x86_64.rpm -O

cd /etc/yum.repos.d && sudo curl \
            http://puddle.ceph.redhat.com/puddles/rhscon/2/latest/RHSCON-2.repo -O

sudo yum install supervisor python-zmq python-msgpack

sudo rpm -ivh --nodeps calamari-server-1.4.0-rc8_3_g87c85f0.el7.centos.x86_64.rpm 

sudo calamari-ctl initialize # expected to emit an ERROR, ignore for now

# edit /etc/calamari/calamari.conf to enable the salt events
emit_events_to_salt_event_bus = True

sudo supervisorctl restart all

now if you've connected the salt-minion to the master you should be able to see events happen by running this:
sudo salt-run state.event pretty=True

on the salt-master


# you may need to allow the firewall to open up ports 4505 and 4506 on the salt-master node
Comment 4 Darshan 2016-06-10 04:00:47 EDT
The fix works as expected. Tried bringing down few osds and monitors in the ceph cluster down and calamari pushed events about these state changes to salt bus. These events were available at salt master.

Moving it to verified state.
Comment 6 errata-xmlrpc 2016-08-23 15:31:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.