Bug 1313313 - Gluster manpage doesn't show georeplication options
Gluster manpage doesn't show georeplication options
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.8
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Aravinda VK
: Documentation, Triaged
Depends On: 1293950
Blocks: glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-03-01 06:30 EST by Aravinda VK
Modified: 2016-04-19 03:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293950
Environment:
Last Closed: 2016-03-22 04:15:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2016-03-01 06:30:13 EST
+++ This bug was initially created as a clone of Bug #1293950 +++

Description of problem:

gluster (cli) does not have any indication of geo-replication page entries.


Version-Release number of selected component (if applicable):RHGS and upstream


How reproducible: 100%


Steps to Reproduce:
1. man gluster
2. search for geo-replication

Actual results:
:( ... nothing


Expected results:
command listing :
volume geo-replication <MASTER> <SLAVE> {start|status|stop|create|delete...}

--- Additional comment from Vijay Bellur on 2015-12-23 11:33:02 EST ---

REVIEW: http://review.gluster.org/13073 (gluster man page: adding geo-replication chapter) posted (#1) for review on master by Cedric Buissart (cedric.buissart@gmail.com)

--- Additional comment from Cedric Buissart on 2015-12-23 11:40:41 EST ---

`gluster help` does not currently show geo-replication options either. but I am unsure how to add that, because it does not seem to have a corresponding callbacks function.

--- Additional comment from Vijay Bellur on 2016-01-29 11:21:48 EST ---

REVIEW: http://review.gluster.org/13073 (gluster man page: adding geo-replication chapter) posted (#2) for review on master by Cedric Buissart (cedric.buissart@gmail.com)

--- Additional comment from Vijay Bellur on 2016-02-06 10:08:52 EST ---

REVIEW: http://review.gluster.org/13073 (gluster man page: adding geo-replication chapter) posted (#3) for review on master by Cedric Buissart (cedric.buissart@gmail.com)

--- Additional comment from Vijay Bellur on 2016-02-10 03:14:32 EST ---

REVIEW: http://review.gluster.org/13073 (gluster man page: adding geo-replication chapter) posted (#4) for review on master by Cedric Buissart (cedric.buissart@gmail.com)

--- Additional comment from Vijay Bellur on 2016-03-01 02:59:00 EST ---

COMMIT: http://review.gluster.org/13073 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 487b3a65d3cebefac93a30222eb81b0a7465c778
Author: Cedric Buissart <cbuissar@redhat.com>
Date:   Wed Dec 23 17:29:50 2015 +0100

    gluster man page: adding geo-replication chapter
    
    geo-replication options are currently missing from gluster(8) man page.
    
    Change-Id: I5d24de856be264e63d3ff49f9b82346476f20473
    BUG: 1293950
    Signed-off-by: Cedric Buissart <cbuissar@redhat.com>
    Reviewed-on: http://review.gluster.org/13073
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Aravinda VK <avishwan@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 1 Vijay Bellur 2016-03-01 06:30:49 EST
REVIEW: http://review.gluster.org/13561 (gluster man page: adding geo-replication chapter) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2016-03-05 18:52:09 EST
COMMIT: http://review.gluster.org/13561 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit a502ed404beb29e9c0a212489e19f636a1cbc442
Author: Cedric Buissart <cbuissar@redhat.com>
Date:   Wed Dec 23 17:29:50 2015 +0100

    gluster man page: adding geo-replication chapter
    
    geo-replication options are currently missing from gluster(8) man page.
    
    Change-Id: I5d24de856be264e63d3ff49f9b82346476f20473
    BUG: 1313313
    Signed-off-by: Cedric Buissart <cbuissar@redhat.com>
    Reviewed-on: http://review.gluster.org/13073
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Aravinda VK <avishwan@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    (cherry picked from commit 487b3a65d3cebefac93a30222eb81b0a7465c778)
    Reviewed-on: http://review.gluster.org/13561
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Kaushal 2016-04-19 03:21:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.