Bug 1313318 - X/Intel display/Regression: flickering display on 4.4.2-301
X/Intel display/Regression: flickering display on 4.4.2-301
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 06:40 EST by Dr. David Alan Gilbert
Modified: 2016-03-15 16:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 21:27:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dr. David Alan Gilbert 2016-03-01 06:40:20 EST
Description of problem:
After upgrade to 4.4.2-301.fc23 kernel, I get very bad flickering on the display; it seems to happen mainly as I move the mouse between the internal and external display and occasional other times.  The flicker varies between the screen or a section of the screen flickering black or the screen distorting (as if the lines don't quite line up?)
It's fine returning to 4.3.5-300.
I'm running xfce, so there's no fancy graphics going on.

Hardware: Lenovo T530 (1920x1080 internal + external 1920x1080 on VGA)
          00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core 
           processor Graphics Controller (rev 09)


Version-Release number of selected component (if applicable):
kernel-core-4.4.2-301.fc23.x86_64
xorg-x11-drv-intel-2.99.917-19.20151206.fc23.x86_64

How reproducible:
100%?  Noticed it first this morning (after update yesterday), rebooted, still happened, booted into old 4.3.5 and it's happy.

Steps to Reproduce:
1. Boot, start X, open a few things on each display
2. move mouse back and forward between displays
3.

Actual results:
Screen flashes black/odd temporary distortions

Expected results:
Stable display

Additional info:
Note I see in my logs

Mar 01 11:27:25 dgilbert-t530 kernel: [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
Mar 01 11:27:25 dgilbert-t530 kernel: [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun

but I see the same thing on the working kernel as well.
However with the broken kernel I thought I saw some text on the console just prior to the luks unlock screen appearing, and I thought it looked like the same text; I don't see it at that point with the working kernel.
Comment 1 Christian Stadelmann 2016-03-01 08:03:45 EST
Same issue here on both KDE Plasma (X11) and Gnome (Wayland) sessions. Hardware is a Intel 1st Gen Core processor.

kernel-4.4.3-300.fc23.x86_64 and kernel-4.4.2-300.fc23.x86_64
xorg-x11-drv-intel-2.99.917-19.20151206.fc23.x86_64

Note that these flashes behave like the F22 wayland freeze exception bug #1218688: The screen flashes black on all lines below mouse cursor for a short time (probably one single frame). Flicker only happens while moving the mouse, not triggered by anything else. This time it isn't happening all the time but no matter whether I use X11 or Wayland.


Additional info:
kernel-4.3.5-300.fc23.x86_64 is not affected.

I'm seeing bug #1312610 and #1312678. And a similiar error in syslog as noted above:
kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
kernel: [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun


Furthermore I'm getting those error messages:

 gnome-shell-wayland.desktop[3359]: (EE) glamor0: GL error: FS SIMD8 shader: 302 inst, 0 loops, 4232 cycles, 0:0 spills:fills, Promoted 0 constants, compacted 4832 to 4240 bytes.
 gnome-shell-wayland.desktop[3359]: (EE) glamor0: GL error: FS SIMD16 shader: 304 inst, 0 loops, 4630 cycles, 0:0 spills:fills, Promoted 0 constants, compacted 4864 to 4272 bytes.
 gnome-shell-wayland.desktop[3359]: (EE) glamor0: GL error: FS SIMD8 shader: 274 inst, 0 loops, 3830 cycles, 0:0 spills:fills, Promoted 0 constants, compacted 4384 to 3824 bytes.
 gnome-shell-wayland.desktop[3359]: (EE) glamor0: GL error: FS SIMD16 shader: 276 inst, 0 loops, 4180 cycles, 0:0 spills:fills, Promoted 0 constants, compacted 4416 to 3856 bytes.
 gnome-shell-wayland.desktop[3359]: (EE) glamor0: GL error: VS vec4 shader: 8 inst, 0 loops, 190 cycles, compacted 128 to 128 bytes.
Comment 2 Dr. David Alan Gilbert 2016-03-01 08:59:04 EST
maybe same as bug 1310252.
Comment 3 Laura Abbott 2016-03-01 13:38:52 EST
There was a potential flickering fix but I didn't pick it up because I saw a report it didn't fix anything. If you'd like to give it a test to really confirm, please try http://koji.fedoraproject.org/koji/taskinfo?taskID=13191219 when it finishes.
Comment 4 Christian Stadelmann 2016-03-01 15:37:25 EST
(In reply to Laura Abbott from comment #3)
> There was a potential flickering fix but I didn't pick it up because I saw a
> report it didn't fix anything. If you'd like to give it a test to really
> confirm, please try
> http://koji.fedoraproject.org/koji/taskinfo?taskID=13191219 when it finishes.

This build fixes the bug. Before applying (with 4.4.2 and "stock" 4.4.3 kernels) I could reliably reproduce flicker when dragging the map on http://flood.firetree.net . Now I can't reproduce the flicker any more.

The first set of error messages from description any comment #1 seems to be gone, the second set of errors from comment #2 is still present and so probably unrelated.
Comment 5 Laura Abbott 2016-03-02 13:38:24 EST
Thanks for testing. I'm going to bring the patch into F23. It should show up in the build for 4.4.4 which should show up in testing on Thursday or Friday
Comment 6 Dr. David Alan Gilbert 2016-03-04 04:24:22 EST
Confirm that 4.4.3-300.rhbz1313318.fc23.x86_64 fixes it.  Thanks!

Dave
Comment 7 Fedora Update System 2016-03-05 18:19:37 EST
kernel-4.4.4-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-746bb5851d
Comment 8 Fedora Update System 2016-03-05 18:22:31 EST
kernel-4.4.4-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6cfaff4b1
Comment 9 Fedora Update System 2016-03-06 19:22:48 EST
kernel-4.4.4-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-746bb5851d
Comment 10 Fedora Update System 2016-03-06 19:26:45 EST
kernel-4.4.4-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e6cfaff4b1
Comment 11 Fedora Update System 2016-03-11 08:26:35 EST
kernel-4.4.4-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-03-11 19:50:57 EST
kernel-4.4.4-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Dr. David Alan Gilbert 2016-03-15 16:05:24 EDT
Confirm 4.4.4-301.fc23 is good for me - thanks!

Dave

Note You need to log in before you can comment on or make changes to this bug.