Bug 1313431 - Creating a 'new host' fails for lifecycle_env and content_view saying "can't be blank"
Creating a 'new host' fails for lifecycle_env and content_view saying "can't ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Partha Aji
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
: 1317071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 10:24 EST by Kedar Bidarkar
Modified: 2016-07-27 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:03:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14166 None None None 2016-04-22 12:02 EDT

  None (edit)
Description Kedar Bidarkar 2016-03-01 10:24:38 EST
Description of problem:

Creating a 'new host' fails for lifecycle_env and content_view saying "can't be blank", even though these values were set.

Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP1

How reproducible:


Steps to Reproduce:
1. Create a "new host"
2. Provide "life-cycle env" and "content-view" values and also all the other needed values.
3. Click submit button.

Actual results:
To get a message "can't be blank" for "lifecycle-env" and "content-view".


Expected results:
"New host" page submission should be successful.
Additional info:

workaround: Again provide the values of "lifecycle-env" and "content-view".
Comment 2 Justin Sherrill 2016-03-11 16:22:36 EST
*** Bug 1317071 has been marked as a duplicate of this bug. ***
Comment 3 Partha Aji 2016-03-11 16:49:28 EST
Created redmine issue http://projects.theforeman.org/issues/14166 from this bug
Comment 4 Partha Aji 2016-03-11 17:25:57 EST
Being handled here -> https://github.com/theforeman/foreman/pull/3309
Comment 5 Bryan Kearney 2016-03-11 18:10:12 EST
Upstream bug component is Provisioning
Comment 7 Bryan Kearney 2016-03-28 12:10:40 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14166 has been closed
-------------
Partha Aji
The title is more of a symptom, but the root cause for this bug is this line in the upstream foreman.
https://github.com/theforeman/foreman/blob/develop/app/models/concerns/facets/managed_host_extensions.rb#L39
<pre>
     def register_facet_relation(klass, facet_config)
        klass.class_eval do
          has_one facet_config.name, :class_name => facet_config.model.name, :foreign_key => :host_id, :inverse_of => :host
          accepts_nested_attributes_for facet_config.name, :update_only => true
          ...
</pre>

Basically accepts_nested_attributes_for usage does not provide an easy way to include in a form without sending blank attributes

-------------
Partha Aji
Applied in changeset commit:5d64eef2cba8e56ad39510c3bd1d724bd52762eb.
Comment 8 Kedar Bidarkar 2016-04-06 12:31:58 EDT
VERIFIED with sat62-snap6


This issue is not seen anymore with latest snaps.
Comment 10 errata-xmlrpc 2016-07-27 05:03:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.