Bug 1313551 - [RFE] Manifest Import should be asynchronous
[RFE] Manifest Import should be asynchronous
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stead
Katello QA List
:
Depends On:
Blocks: 1193803 1334627
  Show dependency treegraph
 
Reported: 2016-03-01 16:35 EST by Barnaby Court
Modified: 2016-11-16 04:15 EST (History)
2 users (show)

See Also:
Fixed In Version: candlepin-2.0.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 10:51:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barnaby Court 2016-03-01 16:35:12 EST
Importing manifests can be a very time consuming operation. For large manifests this process can take from half an hour to mulitple hours. That is well outside of the reasonable period of time for a synchronous REST call. 

The REST endpoint for importing a manifest should be converted to an asynchronous endpoint.
Comment 1 Michael Stead 2016-06-17 10:54:55 EDT
Pull Request:
https://github.com/candlepin/candlepin/pull/1263
Comment 2 Barnaby Court 2016-07-22 10:51:50 EDT
Marking as closed per Candlepin procedures as a fix has been merged or it has been determined to not be an issue.

Note You need to log in before you can comment on or make changes to this bug.