Bug 1334627 - Error uploading Manifest
Summary: Error uploading Manifest
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1313551
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-10 08:08 UTC by jnikolak
Modified: 2019-09-26 14:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-11 05:54:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
manifest_sub_error (50.96 KB, image/png)
2016-05-10 08:08 UTC, jnikolak
no flags Details
foreman_debug3 (373.38 KB, application/x-xz)
2016-05-10 08:16 UTC, jnikolak
no flags Details

Description jnikolak 2016-05-10 08:08:52 UTC
Created attachment 1155611 [details]
manifest_sub_error

Description of problem:

Manifest fails to upload


Steps to Reproduce:
1. generate a new manifest on customer portal
2. Ensure that pulp is not running(this was not intentional to find the bug)
3. Try to upload the manifest just generated
4. It will fail with error:
Katello::Resources::Candlepin::Owner: Request Timeout  (POST /candlepin/owners/MyOrg/imports)

5. Then start katello to ensure all services are up
# hammer ping to confirm

6. Try to upload the manifest but it gives error message
Import is the same as existing data

However on the left frame, it shows no subscriptions.

Attached screenshot.


Issue resolved by doing:
https://access.redhat.com/solutions/2305331

Comment 1 jnikolak 2016-05-10 08:16:42 UTC
Created attachment 1155613 [details]
foreman_debug3

Comment 2 Evgeni Golov 2016-05-10 08:20:45 UTC
I also encountered that on my testinstall, however my pulp was running fine while the initial import of the Manifest errored out with "RestClient::RequestTimeout: Katello::Resources::Candlepin::Owner: Request Timeout  (POST /candlepin/owners/ACME/imports)"

For me just clicking "refresh manifest" was enough to fix that issue, though.

Comment 3 Barnaby Court 2016-05-10 13:22:30 UTC
This will require changing the manifest import from a synchronous to an asynchronous call. See the upstream bug for the details of that call.

Comment 4 Mike McCune 2016-05-11 05:54:56 UTC
If Pulp isn't running, many many things will fail besides manifest import. We currently require all services to be running for Satellite to be functional and anything less is an error state that must be resolved before continuing.

This isn't new for 6.2, and would behave the same in 6.1 or older.

That said, Satellite should show the user in a much more obvious manner that required services are not functioning upon login. If Pulp was down, we should have a big banner/error or something that indicates they should cease trying to utilize the Satellite and resolve the issue. 

Essentially a heartbeat or monitor to notify that things weren't working properly.  I searched for an RFE in this area and couldn't find one so I filed a new one:

https://bugzilla.redhat.com/show_bug.cgi?id=1334992


feel free to comment there.

As for Evgeni's comment here:

https://bugzilla.redhat.com/show_bug.cgi?id=1334627#c2

that is a valid issue worth investigating but is a different bug that I filed here:

https://bugzilla.redhat.com/show_bug.cgi?id=1334996

this is a genuine issue, our default timeout needs to be increased, I'm glad this was spotted as it often only occurs with large manifests or slower VMs.

I'm going to close the original bug because it is a bit vague and I'd prefer to have 2 different bugs to handle this.

Mike


Note You need to log in before you can comment on or make changes to this bug.