Bug 1313766 - Installer does not expose option to install remote execution plugin on smart proxy
Installer does not expose option to install remote execution plugin on smart ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Marek Hulan
Lukas Pramuk
http://projects.theforeman.org/issues...
: Triaged
: 1316947 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 05:20 EST by Marek Hulan
Modified: 2016-07-27 05:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13951 None None None 2016-03-11 09:00 EST

  None (edit)
Description Marek Hulan 2016-03-02 05:20:40 EST
Since there's no mention of plugin in katello scenario, the option to enable it is missing when running foreman-installer.
Comment 1 Marek Hulan 2016-03-02 05:20:44 EST
Created from redmine issue http://projects.theforeman.org/issues/13951
Comment 2 Marek Hulan 2016-03-02 05:20:48 EST
Upstream bug assigned to mhulan@redhat.com
Comment 4 Bryan Kearney 2016-03-02 10:04:28 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13951 has been closed
-------------
Marek Hulán
Applied in changeset commit:katello-installer|8c27d10955df8557257261c1e3fbc823a45dbadf.
Comment 5 Stephen Benjamin 2016-03-11 09:01:08 EST
*** Bug 1316947 has been marked as a duplicate of this bug. ***
Comment 7 Lukas Pramuk 2016-04-27 05:42:14 EDT
VERIFIED.

@Sat6.2.0-Beta-Snap9.2
foreman-installer-1.11.0.3-1.el7sat.noarch

# foreman-installer -S katello -h
...
    --[no-]enable-foreman-proxy-plugin-remote-execution-ssh Enable 'foreman_proxy_plugin_remote_execution_ssh' puppet module (default: true)
...

# foreman-installer -S capsule -h
...
    --[no-]enable-foreman-proxy-plugin-remote-execution-ssh Enable 'foreman_proxy_plugin_remote_execution_ssh' puppet module (default: true)
...

>>> both scenarios have the option
Comment 9 errata-xmlrpc 2016-07-27 05:03:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.