Bug 1313783 - Regression 'kubectl config view' no longer has --output=json flag
Regression 'kubectl config view' no longer has --output=json flag
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kubernetes (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Chaloupka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 05:51 EST by Stef Walter
Modified: 2016-03-31 20:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 20:28:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2016-03-02 05:51:38 EST
Description of problem:

The 'kubectl config view' no longer has --output=json flag.


Version-Release number of selected component (if applicable):

kubernetes-client-1.2.0-0.12.alpha6.gitf0cd09a.fc23.x86_64


How reproducible:

Every time


Steps to Reproduce:
1. kubectl config view --output=json

Actual results:

unknown flag: --output[root@localhost ~]# 

Expected results:

JSON output for kubernetes config as seen with previous kubernetes-client versions.

$ kubectl config view --output=json
{
    "kind": "Config",
    "apiVersion": "v1",
    "preferences": {},
    "clusters": [
...
Comment 1 Jan Chaloupka 2016-03-02 06:44:48 EST

*** This bug has been marked as a duplicate of bug 1313787 ***
Comment 2 Fedora Update System 2016-03-02 07:56:35 EST
kubernetes-1.2.0-0.13.alpha6.gitf0cd09a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8bc7ba5f6b
Comment 3 Fedora Update System 2016-03-08 14:03:29 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a89f5ce5f4
Comment 4 Fedora Update System 2016-03-09 17:56:01 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a89f5ce5f4
Comment 5 Fedora Update System 2016-03-31 20:27:57 EDT
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.