Bug 1313787 - Regression 'kubectl create -f path' no longer works
Regression 'kubectl create -f path' no longer works
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kubernetes (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Chaloupka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-02 05:57 EST by Stef Walter
Modified: 2016-03-31 20:28 EDT (History)
6 users (show)

See Also:
Fixed In Version: kubernetes-1.2.0-0.13.alpha6.gitf0cd09a.fc23 kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 20:28:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2016-03-02 05:57:23 EST
Description of problem:

The syntax 'kubectl create -f path.json' is often used to create objects in kubernetes. It is no longer accepted.

Version-Release number of selected component (if applicable):

kubernetes-client-1.2.0-0.12.alpha6.gitf0cd09a.fc23.x86_64


How reproducible:

Every time.


Steps to Reproduce:
1. kubectl create -f test.json

Actual results:

unknown shorthand flag: 'f' in -f[root@localhost ~]# rpm -q kubernetes-client

Expected results:

Create the objects. Or tell us that test.json doesn't exist (if it doesn't).
Comment 1 Jan Chaloupka 2016-03-02 06:41:42 EST
This is fixed here https://bodhi.fedoraproject.org/updates/FEDORA-2016-8bc7ba5f6b
Comment 2 Jan Chaloupka 2016-03-02 06:44:48 EST
*** Bug 1313783 has been marked as a duplicate of this bug. ***
Comment 3 Stef Walter 2016-03-02 06:49:23 EST
Yup, can confirm this is fixed in http://koji.fedoraproject.org/koji/buildinfo?buildID=740256
Comment 4 Fedora Update System 2016-03-08 14:02:57 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a89f5ce5f4
Comment 5 Fedora Update System 2016-03-09 17:55:43 EST
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a89f5ce5f4
Comment 6 Fedora Update System 2016-03-31 20:27:39 EDT
kubernetes-1.2.0-0.15.alpha6.gitf0cd09a.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.