Bug 131381 - while upgrading to rawhide-20040831, yum crashed; after crash, yum refuses to run
while upgrading to rawhide-20040831, yum crashed; after crash, yum refuses to...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 131570 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-31 15:42 EDT by Daniel Reed
Modified: 2014-01-21 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 09:52:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix to yum-2.1.0 to stop it from throwing an error executing "yum clean" (344 bytes, patch)
2004-09-01 09:15 EDT, Alistair Riddoch
no flags Details | Diff

  None (edit)
Description Daniel Reed 2004-08-31 15:42:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Completing update for kde-i18n-Spanish  - 335/337
Completing update for gnome-desktop  - 336/337
Completing update for gnome-applets  - 337/337
Kernel Updated/Installed, checking for bootloader
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?

  File "/usr/share/yum/yummain.py", line 375, in main

  File "/usr/share/yum/pkgaction.py", line 588, in kernelupdate
ImportError: No module named checkbootloader
[root@localhost ~]# yum check-update
Traceback (most recent call last):
  File "/usr/share/yum/yummain.py", line 135, in ?
    main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 62, in main
    result, resultmsgs = base.doCommands()
TypeError: unpack non-sequence
[root@localhost ~]# yum check-update
Traceback (most recent call last):
  File "/usr/share/yum/yummain.py", line 135, in ?
    main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 62, in main
    result, resultmsgs = base.doCommands()
TypeError: unpack non-sequence
[root@localhost ~]# rpm -q yum rpm
yum-2.1.0-1
rpm-4.3.2-0.10
[root@localhost ~]#

Version-Release number of selected component (if applicable):
yum-2.1.0-1 rpm-4.3.2-0.10

How reproducible:
Always
Comment 1 Daniel Reed 2004-08-31 16:06:54 EDT
Downgrading yum to 2.0.7-3 allows yum to function. After re-upgrading
to 2.1.0-1 by itself, the problem reappears.
Comment 2 Seth Vidal 2004-08-31 16:22:22 EDT
- yum updated itself and then tried to load things from the in-memory
program from the now-erased yum 2.0.7.

That's breakage that I _know_ is going to occur going to this version.

update yum first then you can update everything else.

check-update isn't implemented in yum 2.1.0 yet, - run 'yum list
updates' instead

I need to catch the silly error, though.




Comment 3 Alistair Riddoch 2004-09-01 09:15:15 EDT
Created attachment 103336 [details]
Fix to yum-2.1.0 to stop it from throwing an error executing "yum clean"

I got a very similar error when running "yum clean" with the new version. This
turned out to be because YumBaseCli.doCommands() returns None when the command
is "clean", rather than the number and string specified in the function docs.
The attached patch fixes the problem by returning the apropriate value for
success. "yum clean" now runs without throwing an error, but does not appear to
clean anything up.

It is possible that the error reported above when using "check-update" could be
partly solved by adding an else clause to the end of YumBaseCli.doCommands() as

this function also return None if none of the elif: clauses are matched.
Comment 4 Seth Vidal 2004-09-01 09:52:06 EDT
it's fixed in cvs.
Comment 5 Seth Vidal 2004-09-02 09:01:26 EDT
*** Bug 131570 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.